Blank/black screen for 6.6 - any general debugging hints?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Blank/black screen for 6.6 - any general debugging hints?

lu hu
Hello,

I was using 6.5 on a desktop PC.

I did a sysupgrade, but after the blue boot text, I only get black/blank screen.

I don't think it is just the screen, since I cannot reach it via network.

I booted the 6.6 bsd.rd then did a clean install with 6.6. The same issue.

I downloaded the 6.5 bsd.rd/sets and clean installed it. IT WORKED! YAY!!!

So looks like, there is some issue with 6.6 on my HW.

So I will probably skip 6.6 on this HW and hope 6.7 will work :)


BUT:

I didn't found any MAN pages, DOCs, how to troubleshoot these kind of black/blank screen boot issues.

Any hints in general, what can I do next time to avoid a clean install of the older major version?

Many thanks and wishing peaceful holidays!

Reply | Threaded
Open this post in threaded view
|

Re: Blank/black screen for 6.6 - any general debugging hints?

Christer Solskogen-3
Could you post a dmesg for 6.5 and for current?

On Mon, Dec 30, 2019, 19:12 lu hu <[hidden email]> wrote:

> Hello,
>
> I was using 6.5 on a desktop PC.
>
> I did a sysupgrade, but after the blue boot text, I only get black/blank
> screen.
>
> I don't think it is just the screen, since I cannot reach it via network.
>
> I booted the 6.6 bsd.rd then did a clean install with 6.6. The same issue.
>
> I downloaded the 6.5 bsd.rd/sets and clean installed it. IT WORKED! YAY!!!
>
> So looks like, there is some issue with 6.6 on my HW.
>
> So I will probably skip 6.6 on this HW and hope 6.7 will work :)
>
>
> BUT:
>
> I didn't found any MAN pages, DOCs, how to troubleshoot these kind of
> black/blank screen boot issues.
>
> Any hints in general, what can I do next time to avoid a clean install of
> the older major version?
>
> Many thanks and wishing peaceful holidays!
>
>
Reply | Threaded
Open this post in threaded view
|

Re: Blank/black screen for 6.6 - any general debugging hints?

Tom Smyth
In reply to this post by lu hu
Hi Lu,

at a guess it could be that your hardware needs a  graphics driver
that requires root to run...
since the Xorg security bug ...
OpenBSD dont support graphics drivers that require root privileges to run...
(or something like that) ...
as Christer suggested...  dmesgs need to be included in requests
/feedback (especially about hardware)
hope this helps,

On Mon, 30 Dec 2019 at 18:23, lu hu <[hidden email]> wrote:

>
> Hello,
>
> I was using 6.5 on a desktop PC.
>
> I did a sysupgrade, but after the blue boot text, I only get black/blank screen.
>
> I don't think it is just the screen, since I cannot reach it via network.
>
> I booted the 6.6 bsd.rd then did a clean install with 6.6. The same issue.
>
> I downloaded the 6.5 bsd.rd/sets and clean installed it. IT WORKED! YAY!!!
>
> So looks like, there is some issue with 6.6 on my HW.
>
> So I will probably skip 6.6 on this HW and hope 6.7 will work :)
>
>
> BUT:
>
> I didn't found any MAN pages, DOCs, how to troubleshoot these kind of black/blank screen boot issues.
>
> Any hints in general, what can I do next time to avoid a clean install of the older major version?
>
> Many thanks and wishing peaceful holidays!
>


--
Kindest regards,
Tom Smyth.

Reply | Threaded
Open this post in threaded view
|

Re: Blank/black screen for 6.6 - any general debugging hints?

Bodie-3
In reply to this post by lu hu


On 30.12.2019 19:07, lu hu wrote:

> Hello,
>
> I was using 6.5 on a desktop PC.
>
> I did a sysupgrade, but after the blue boot text, I only get
> black/blank screen.
>
> I don't think it is just the screen, since I cannot reach it via
> network.
>
> I booted the 6.6 bsd.rd then did a clean install with 6.6. The same
> issue.
>
> I downloaded the 6.5 bsd.rd/sets and clean installed it. IT WORKED!
> YAY!!!
>
> So looks like, there is some issue with 6.6 on my HW.
>
> So I will probably skip 6.6 on this HW and hope 6.7 will work :)
>
>
> BUT:
>
> I didn't found any MAN pages, DOCs, how to troubleshoot these kind of
> black/blank screen boot issues.
>
> Any hints in general, what can I do next time to avoid a clean install
> of the older major version?
>
> Many thanks and wishing peaceful holidays!

https://www.openbsd.org/report.html

Reply | Threaded
Open this post in threaded view
|

Re: Blank/black screen for 6.6 - any general debugging hints?

Boudewijn Dijkstra-3
In reply to this post by lu hu
Op Mon, 30 Dec 2019 19:07:10 +0100 schreef lu hu <[hidden email]>:

> Hello,
>
> I was using 6.5 on a desktop PC.
>
> I did a sysupgrade, but after the blue boot text, I only get black/blank  
> screen.
>
> I don't think it is just the screen, since I cannot reach it via network.
>
> I booted the 6.6 bsd.rd then did a clean install with 6.6. The same  
> issue.

I had the same issue (I have yet to report it.)  Disabling amdgpu fixed it  
for me.


--
Gemaakt met Opera's e-mailprogramma: http://www.opera.com/mail/