Anybody build Lazarus with OpenBSD's FPC 3.0.0?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Anybody build Lazarus with OpenBSD's FPC 3.0.0?

alan01346
I'm getting some type conversion errors which I didn't get with FPC
2.6.4 from ports in 5.7.  I'm not sure what's at the root of it but
I've got a post on the Lazarus forum at:

http://forum.lazarus.freepascal.org/index.php?topic=32293.msg208126#msg208126

--
Credit is the root of all evil.  - AB1JX

Reply | Threaded
Open this post in threaded view
|

Re: Anybody build Lazarus with OpenBSD's FPC 3.0.0?

Stuart Henderson
On 2016/04/14 11:03, Alan Corey wrote:
> I'm getting some type conversion errors which I didn't get with FPC
> 2.6.4 from ports in 5.7.  I'm not sure what's at the root of it but
> I've got a post on the Lazarus forum at:
>
> http://forum.lazarus.freepascal.org/index.php?topic=32293.msg208126#msg208126

I have on i386 about 40 times since fpc 3.0.0 went in, it's unreliable
but works more often than not.

Reply | Threaded
Open this post in threaded view
|

Re: Anybody build Lazarus with OpenBSD's FPC 3.0.0?

Juan Francisco Cantero Hurtado
In reply to this post by alan01346
On Thu, Apr 14, 2016 at 11:03:47AM -0400, Alan Corey wrote:
> I'm getting some type conversion errors which I didn't get with FPC
> 2.6.4 from ports in 5.7.  I'm not sure what's at the root of it but
> I've got a post on the Lazarus forum at:
>
> http://forum.lazarus.freepascal.org/index.php?topic=32293.msg208126#msg208126

You're mixing a lot of things there. Never use a -current port with a
-stable base. Update to 5.9 and install the Lazarus package.


--
Juan Francisco Cantero Hurtado http://juanfra.info

Reply | Threaded
Open this post in threaded view
|

Re: Anybody build Lazarus with OpenBSD's FPC 3.0.0?

alan01346
In reply to this post by alan01346
On my laptop, which I guess is 64-bit capable, I installed FPC 3.0.0
by copying the port from 5.9 ports, then installed Lazarus 1.6
directly from the tarball, no problem at all.  Might be a 32/64 bit
thing, this is an old Dell Optiplex GX270 from 2002.  Both under
OpenBSD 5.7.  A few differences in other installed software between
the 2 machines but not many.

--
Credit is the root of all evil.  - AB1JX