Any chance of including new RedNoteBook?

Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Any chance of including new RedNoteBook?

Daniel Villarreal
re https://github.com/jendrikseipp/rednotebook/blob/master/README.md

Requirements
    Python (>= 3.4): https://www.python.org
    GTK+ (>= 3.10): https://www.gtk.org
    WebKitGTK+ (>= 2.16): https://webkitgtk.org
    PyYAML: http://pyyaml.org


http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/productivity/ \
rednotebook /pkg/Attic/DESCR
"Revision 1.2, Tue Jan 31 07:02:44 2017 UTC (5 months, 2 weeks ago) by
ajacoutot ...
FILE REMOVED
WebKitGTK+ 2.4 is full of security holes and not maintained upstream
anymore. So stop coping with the insanity and let's remove py-webkitgtk
(people should be using the newer WebKit introspection libs) and
rednotebook which depends on it and hasn't been updated in years."

https://github.com/jendrikseipp/rednotebook/blob/master/CHANGELOG
"== 2.0 (2017-05-19) ==
* Port to Python 3 and GTK 3."


https://webkitgtk.org/releases/
webkitgtk-2.4.0a.tar.xz 2014-09-30 09:22 9.6M
webkitgtk-2.16.0.tar.xz 2017-03-20 12:00 14M

Any change in the situation ?

Thanks!
Daniel Villarreal

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Any chance of including new RedNoteBook?

Flipchan
Can't u just gnumake the libs and compile it ?

On July 21, 2017 6:11:41 AM GMT+02:00, Daniel Villarreal <[hidden email]> wrote:

>re https://github.com/jendrikseipp/rednotebook/blob/master/README.md
>
>Requirements
>    Python (>= 3.4): https://www.python.org
>    GTK+ (>= 3.10): https://www.gtk.org
>    WebKitGTK+ (>= 2.16): https://webkitgtk.org
>    PyYAML: http://pyyaml.org
>
>
>http://cvsweb.openbsd.org/cgi-bin/cvsweb/ports/productivity/ \
>rednotebook /pkg/Attic/DESCR
>"Revision 1.2, Tue Jan 31 07:02:44 2017 UTC (5 months, 2 weeks ago) by
>ajacoutot ...
>FILE REMOVED
>WebKitGTK+ 2.4 is full of security holes and not maintained upstream
>anymore. So stop coping with the insanity and let's remove py-webkitgtk
>(people should be using the newer WebKit introspection libs) and
>rednotebook which depends on it and hasn't been updated in years."
>
>https://github.com/jendrikseipp/rednotebook/blob/master/CHANGELOG
>"== 2.0 (2017-05-19) ==
>* Port to Python 3 and GTK 3."
>
>
>https://webkitgtk.org/releases/
>webkitgtk-2.4.0a.tar.xz 2014-09-30 09:22 9.6M
>webkitgtk-2.16.0.tar.xz 2017-03-20 12:00 14M
>
>Any change in the situation ?
>
>Thanks!
>Daniel Villarreal

--
Take Care Sincerely flipchan layerprox dev
Loading...