AML PARSE ERROR

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

AML PARSE ERROR

karthic kumaran
Hello,

I recently upgraded to -current because the intel graphics driver in the
4.8 release freezes my computer. I have a Core i3 with integrated
graphics, every time i boot my laptop with multiprocessor turned on i
get an AML PARSE ERROR. I am running the GENERIC.MP kernel with
INTELDRM_GEM. Below is a copy of my dmesg,

OpenBSD 4.9-beta (GEM) #2: Mon Jan 31 14:42:39 IST 2011
     [hidden email]:/usr/src/sys/arch/i386/compile/GEM
RTC BIOS diagnostic error 80<clock_battery>
cpu0: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz ("GenuineIntel"
686-class) 2.13 GHz
cpu0:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT
real mem  = 3076341760 (2933MB)
avail mem = 3015868416 (2876MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 02/10/10, SMBIOS rev. 2.6 @
0xea000 (37 entries)
bios0: vendor Hewlett-Packard version "F.07" date 02/10/2010
bios0: Hewlett-Packard HP G62 Notebook PC
acpi0 at bios0: rev 2
acpi0: sleep states S0 S3 S4 S5
acpi0: tables DSDT FACP ASF! HPET APIC MCFG SLIC BOOT ASPT WDAT SSDT
acpi0: wakeup devices P0P2(S4) PEGP(S4) P0P3(S4) PEGP(S4) P0P1(S4)
PS2K(S3) PS2M(S3) EHC1(S0) USB1(S0) USB2(S0) USB3(S0) USB4(S0) EHC2(S0)
USB5(S0) USB6(S0) USB7(S0) HDEF(S0) RP01(S4) RP02(S4) PXSX(S5) RP03(S4)
RP04(S4) RP05(S4) RP08(S4) PXSX(S0)
acpitimer0 at acpi0: 3579545 Hz, 24 bits
acpihpet0 at acpi0: 14318179 Hz
acpimadt0 at acpi0 addr 0xfee00000: PC-AT compat
cpu0 at mainbus0: apid 0 (boot processor)
cpu0: apic clock running at 133MHz
cpu1 at mainbus0: apid 1 (application processor)
cpu1: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz ("GenuineIntel"
686-class) 2.13 GHz
cpu1:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT
cpu2 at mainbus0: apid 4 (application processor)
cpu2: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz ("GenuineIntel"
686-class) 2.13 GHz
cpu2:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT
cpu3 at mainbus0: apid 5 (application processor)
cpu3: Intel(R) Core(TM) i3 CPU M 330 @ 2.13GHz ("GenuineIntel"
686-class) 2.13 GHz
cpu3:
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CFLUSH,DS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,SBF,SSE3,MWAIT,DS-CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,SSE4.2,POPCNT
ioapic0 at mainbus0: apid 2 pa 0xfec00000, version 20, 24 pins
ioapic0: misconfigured as apic 0, remapped to apid 2
acpimcfg0 at acpi0 addr 0xe0000000, bus 0-255
acpiprt0 at acpi0: bus 0 (PCI0)
acpiprt1 at acpi0: bus -1 (P0P2)
acpiprt2 at acpi0: bus -1 (P0P3)
acpiprt3 at acpi0: bus 4 (P0P1)
acpiprt4 at acpi0: bus 2 (RP01)
acpiprt5 at acpi0: bus 3 (RP02)
acpiprt6 at acpi0: bus -1 (RP03)
acpiprt7 at acpi0: bus -1 (RP04)
acpiprt8 at acpi0: bus -1 (RP05)
acpiprt9 at acpi0: bus -1 (RP08)
acpiec0 at acpi0### AML PARSE ERROR (0x105b8): Undefined name:
\\_PR_.CPU0._PPC
error evaluating: \\_SB_.PCI0.LPCB.EC0_._REG
acpiec _REG failed, broken BIOS

acpicpu0 at acpi0: C1, PSS
acpicpu1 at acpi0: C1, PSS
acpicpu2 at acpi0: C1, PSS
acpicpu3 at acpi0: C1, PSS
acpitz0 at acpi0acpitz0: TZ01: failed to read _CRT
: no critical temperature defined
acpibtn0 at acpi0: PWRB
acpibtn1 at acpi0: LID0
acpiac0 at acpi0: AC unit online
acpibat0 at acpi0: BAT0 model "Primary" serial   type LION oem
"Hewlett-Packard"
acpivideo0 at acpi0: GFX0
acpivideo1 at acpi0: VGA_
acpivideo2 at acpi0: VGA_
bios0: ROM list: 0xc0000/0xfa00! 0xd0000/0x2c00!
cpu0: Enhanced SpeedStep 2128 MHz: speeds: 2133, 1999, 1866, 1733, 1599,
1466, 1333, 1199, 1066, 933 MHz
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "Intel Core Host" rev 0x02
vga1 at pci0 dev 2 function 0 "Intel Mobile HD graphics" rev 0x02
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
intagp0 at vga1
agp0 at intagp0: aperture at 0xc0000000, size 0x10000000
inteldrm0 at vga1: apic 2 int 17 (irq 5)
drm0 at inteldrm0
"Intel 3400 MEI" rev 0x06 at pci0 dev 22 function 0 not configured
ehci0 at pci0 dev 26 function 0 "Intel 3400 USB" rev 0x05: apic 2 int 16
(irq 10)
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "Intel EHCI root hub" rev 2.00/1.00 addr 1
azalia0 at pci0 dev 27 function 0 "Intel 3400 HD Audio" rev 0x05: apic 2
int 22 (irq 11)
azalia0: codecs: Realtek/0x0270, Intel/0x2804, using Realtek/0x0270
audio0 at azalia0
ppb0 at pci0 dev 28 function 0 "Intel 3400 PCIE" rev 0x05: apic 2 int 17
(irq 255)
pci1 at ppb0 bus 2
iwn0 at pci1 dev 0 function 0 "Intel WiFi Link 1000" rev 0x00: apic 2
int 16 (irq 10), MIMO 1T2R, BGS, address 00:26:c7:00:fc:58
ppb1 at pci0 dev 28 function 1 "Intel 3400 PCIE" rev 0x05: apic 2 int 16
(irq 255)
pci2 at ppb1 bus 3
re0 at pci2 dev 0 function 0 "Realtek 8101E" rev 0x02: RTL8102EL
(0x2480), apic 2 int 17 (irq 11), address c8:0a:a9:18:c9:44
rlphy0 at re0 phy 7: RTL8201L 10/100 PHY, rev. 1
ehci1 at pci0 dev 29 function 0 "Intel 3400 USB" rev 0x05: apic 2 int 21
(irq 5)
usb1 at ehci1: USB revision 2.0
uhub1 at usb1 "Intel EHCI root hub" rev 2.00/1.00 addr 1
ppb2 at pci0 dev 30 function 0 "Intel 82801BAM Hub-to-PCI" rev 0xa5
pci3 at ppb2 bus 4
pcib0 at pci0 dev 31 function 0 "Intel HM55 LPC" rev 0x05
ahci0 at pci0 dev 31 function 2 "Intel 3400 AHCI" rev 0x05: apic 2 int
19 (irq 10), AHCI 1.3
scsibus0 at ahci0: 32 targets
sd0 at scsibus0 targ 0 lun 0: <ATA, TOSHIBA MK3256GS, LH01> SCSI3
0/direct fixed
sd0: 305245MB, 512 bytes/sec, 625142448 sec total
cd0 at scsibus0 targ 1 lun 0: <hp, DVDRAM GT30L, mP04> ATAPI 5/cdrom
removable
ichiic0 at pci0 dev 31 function 3 "Intel 3400 SMBus" rev 0x05: apic 2
int 19 (irq 10)
iic0 at ichiic0
sdtemp0 at iic0 addr 0x18: se97
spdmem0 at iic0 addr 0x50: 1GB DDR3 SDRAM PC3-10600 SO-DIMM with thermal
sensor
spdmem1 at iic0 addr 0x52: 2GB DDR3 SDRAM PC3-10600 SO-DIMM
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pms0 at pckbc0 (aux slot)
pckbc0: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
mtrr: Pentium Pro MTRR support
uhub2 at uhub0 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
umass0 at uhub2 port 5 configuration 1 interface 0 "Generic USB2.0-CRW"
rev 2.00/58.88 addr 3
umass0: using SCSI over Bulk-Only
scsibus1 at umass0: 2 targets, initiator 0
sd1 at scsibus1 targ 1 lun 0: <Generic-, Multi-Card, 1.00> SCSI0
0/direct removable
sd1: drive offline
uhub3 at uhub1 port 1 "Intel Rate Matching Hub" rev 2.00/0.00 addr 2
uvideo0 at uhub3 port 5 configuration 1 interface 0 "Chicony Corp. HP
Webcam-101" rev 2.00/59.54 addr 3
video0 at uvideo0
vscsi0 at root
scsibus2 at vscsi0: 256 targets
softraid0 at root
root on sd0a swap on sd0b dump on sd0b

Reply | Threaded
Open this post in threaded view
|

Re: AML PARSE ERROR

Philip Guenther-2
On Mon, Jan 31, 2011 at 7:04 AM, karthic kumaran <[hidden email]> wrote:
> I recently upgraded to -current because the intel graphics driver in the 4.8
> release freezes my computer. I have a Core i3 with integrated graphics,
> every time i boot my laptop with multiprocessor turned on i get an AML PARSE
> ERROR. I am running the GENERIC.MP kernel with INTELDRM_GEM.

So, you're running GENERIC.MP, but locally compiled.  What about that
INTERLDRM_GEM option you added, you wonder?  That option has had *NO
EFFECT* for over 8 months!  If you don't understand why you're
building and running a custom kernel, then you shouldn't be.  Just use
GENERIC.MP from the snapshots and save your own time and that of the
developers.

As for the error itself:

> acpiec0 at acpi0### AML PARSE ERROR (0x105b8): Undefined name:
> \\_PR_.CPU0._PPC
> error evaluating: \\_SB_.PCI0.LPCB.EC0_._REG
> acpiec _REG failed, broken BIOS

So, OpenBSD thinks the BIOS is broken.  Has HP released a BIOS update
for that machine?


Philip Guenther

Reply | Threaded
Open this post in threaded view
|

Re: AML PARSE ERROR

karthic kumaran
> So, you're running GENERIC.MP, but locally compiled.  What about that
> INTERLDRM_GEM option you added, you wonder?  That option has had *NO
> EFFECT* for over 8 months!  If you don't understand why you're
> building and running a custom kernel, then you shouldn't be.  Just use
> GENERIC.MP from the snapshots and save your own time and that of the
> developers.

I was not aware that inteldrm_gem has no effect for 8 months, in my
case x11 will freeze up if i try to run glxgears or even use mplayer
without inteldrm_gem option.

>
> As for the error itself:
>
> > acpiec0 at acpi0### AML PARSE ERROR (0x105b8): Undefined name:
> > \\_PR_.CPU0._PPC
> > error evaluating: \\_SB_.PCI0.LPCB.EC0_._REG
> > acpiec _REG failed, broken BIOS
>
> So, OpenBSD thinks the BIOS is broken.  Has HP released a BIOS update
> for that machine?
>
> Philip Guenther

No HP has not released any BIOS update, i used to run Fedora 13 on my
laptop and it gave the same complaint. However, a kernel upgrade
cleared the error. This error has not caused any problems while
working on the laptop i just wanted to know if this is a hardware
fault or not.

This is my first time reporting a problem to OpenBSD mailing lists,
next time onwards i will send all reports while running a generic
kernel.

I am really sorry if i offended anyone.

Thanks for replying,
Karthic

Reply | Threaded
Open this post in threaded view
|

Re: AML PARSE ERROR

Marco Peereboom
On Tue, Feb 01, 2011 at 02:57:18PM +0530, k3.karthic wrote:

> > So, you're running GENERIC.MP, but locally compiled.  What about that
> > INTERLDRM_GEM option you added, you wonder?  That option has had *NO
> > EFFECT* for over 8 months!  If you don't understand why you're
> > building and running a custom kernel, then you shouldn't be.  Just use
> > GENERIC.MP from the snapshots and save your own time and that of the
> > developers.
>
> I was not aware that inteldrm_gem has no effect for 8 months, in my
> case x11 will freeze up if i try to run glxgears or even use mplayer
> without inteldrm_gem option.

This was fixed but I don't remember when.

>
> >
> > As for the error itself:
> >
> > > acpiec0 at acpi0### AML PARSE ERROR (0x105b8): Undefined name:
> > > \\_PR_.CPU0._PPC
> > > error evaluating: \\_SB_.PCI0.LPCB.EC0_._REG
> > > acpiec _REG failed, broken BIOS
> >
> > So, OpenBSD thinks the BIOS is broken.  Has HP released a BIOS update
> > for that machine?
> >
> > Philip Guenther
>
> No HP has not released any BIOS update, i used to run Fedora 13 on my
> laptop and it gave the same complaint. However, a kernel upgrade
> cleared the error. This error has not caused any problems while
> working on the laptop i just wanted to know if this is a hardware
> fault or not.

Bad BIOS.

See other email I sent you.

> This is my first time reporting a problem to OpenBSD mailing lists,
> next time onwards i will send all reports while running a generic
> kernel.
>
> I am really sorry if i offended anyone.
>
> Thanks for replying,
> Karthic