6.6 pkg_add of firefox vs atk versions

classic Classic list List threaded Threaded
14 messages Options
Reply | Threaded
Open this post in threaded view
|

6.6 pkg_add of firefox vs atk versions

austin

Probably got my packages messed up at some point, and should just stop
doing endless "upgrades", and start clean with 6.7, but for learning
purposes and perspective, would appreciate tips on why doing a pkg_add of
firefox under 6.6 would fail, while looking for a version of atk that that
is not in the packages for 6.6?


farm# pkg_add firefox
quirks-3.187 signed on 2020-05-19T14:41:48Z
Can't install firefox-72.0.2 because of libraries
|library atk-1.0.21809.3 not found
...

But looking at:

https://ftp.openbsd.org/pub/OpenBSD/6.6/packages/amd64/

I only see: atk-2.... and no atk-1....

-------------------------- <clip> ----------------------
at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
atk-2.32.0.tgz               12-Oct-2019 06:06        461597
atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
--------------------------- </clip> -----------------------

I realize that there are dependencies of dependencies going on here. but
for perspective, why wouldn't atk-1... exist in the same package
repository as the 6.6 version of firefox does, if that version (or
probably it's other dependencies) requires it.  Wouldn't package testing
have failed for firefox when it was tested for 6.6?  And if not, why not?

Thanks in advance, for any comment.

Austin Hook






Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Solene Rapenne
On Wed, 29 Jul 2020 09:36:38 -0600 (MDT)
Austin Hook <[hidden email]>:

> Probably got my packages messed up at some point, and should just stop
> doing endless "upgrades", and start clean with 6.7, but for learning
> purposes and perspective, would appreciate tips on why doing a pkg_add of
> firefox under 6.6 would fail, while looking for a version of atk that that
> is not in the packages for 6.6?
>
>
> farm# pkg_add firefox
> quirks-3.187 signed on 2020-05-19T14:41:48Z
> Can't install firefox-72.0.2 because of libraries
> |library atk-1.0.21809.3 not found
> ...
>
> But looking at:
>
> https://ftp.openbsd.org/pub/OpenBSD/6.6/packages/amd64/
>
> I only see: atk-2.... and no atk-1....
>
> -------------------------- <clip> ----------------------
> at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
> atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
> atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
> atk-2.32.0.tgz               12-Oct-2019 06:06        461597
> atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
> atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
> atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
> --------------------------- </clip> -----------------------
>
> I realize that there are dependencies of dependencies going on here. but
> for perspective, why wouldn't atk-1... exist in the same package
> repository as the 6.6 version of firefox does, if that version (or
> probably it's other dependencies) requires it.  Wouldn't package testing
> have failed for firefox when it was tested for 6.6?  And if not, why not?
>
> Thanks in advance, for any comment.
>
> Austin Hook

atk package contains the file
/usr/local/lib/libatk-1.0.so.21809.3

I don't know why pkg_add firefox doesn't work though, can you try
pkg_add -U firefox or pkg_add -u && pkg_add firefox?

Firefox 72.0.2 is the package pulled from package-stable and not
the firefox version that came with 6.6 but it shouldn't fail.

Looking at the package signature, the atk version matches
the 6.6 atk package.

Signature: firefox-72.0.2,5,@desktop-file-utils-0.24p0,
@gtk+2-2.24.32p5,@gtk+3-3.24.12,@icu4c-64.2p0,
@xdg-utils-1.1.3p1,X11-xcb.2.0,X11.17.0,Xcomposite.4.0,
Xcursor.5.0,Xdamage.4.0,Xext.13.0,Xfixes.6.0,Xi.12.1,
Xrender.6.0,Xt.11.0,atk-1.0.21809.3,c++.3.0,c++abi.1.0,c.95.1,
cairo-gobject.2.0,cairo.13.0,fontconfig.13.0,freetype.30.0,
gdk-3.2201.1,gdk-x11-2.0.2400.0,gdk_pixbuf-2.0.3200.1,
gio-2.0.4200.9,glib-2.0.4201.2,gobject-2.0.4200.9,
gthread-2.0.4200.9,gtk-3.2201.0,gtk-x11-2.0.2400.0,icudata.15.0,
icui18n.15.0,icuuc.15.0,intl.6.0,m.10.1,pango-1.0.3800.2,
pangocairo-1.0.3800.1,pangoft2-1.0.3800.1,pthread.26.1,
sndio.7.0,xcb-shm.1.1,xcb.4.0,z.5.0

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2

Thanks Solene,

   I did pkg_add -u && pkg_add firefox and it still failed.  At one point
the -u complains of a "loop" and asks me if I want to proceed anyway
[n,y,a] so I select "a".  After completion pkg_add -u the pkg_add firefox
still fails.

   You pointed out that you don't see atk-1, and I see that I am confusing
the contents of the package with the pkg_name.  So that's one step.

Now if I just try to install atk I get:

farm# pkg_add atk
quirks-3.187 signed on 2020-05-19T14:41:48Z
Can't install atk-2.32.0 because of libraries
|library glib-2.0.4201.2 not found
| /usr/local/lib/libglib-2.0.so.4200.6 (.libs-glib2-2.54.3p1): bad major
| /usr/local/lib/libglib-2.0.so.4201.0 (glib2-2.56.3p0): minor is too
small
|library gobject-2.0.4200.9 not found

so then if I try to install glib I get:

farm# pkg_add glib
quirks-3.187 signed on 2020-05-19T14:41:48Z
Can't find glib
Obsolete package: glib (outdated and/or no longer required by other ports)

So it this a dead end?  And maybe I have to at least try to update to 6.6
stable?  

I agree that these steps are a kind of a resistance to just going to 6.7,
but the failure patterns are instructive to learning useful lessons, so
that's why I think they are of some value.  And maybe some value for
others who scan the list for explanations.

Regards,

Austin Hook
[hidden email]
[hidden email]


On Wed, 29 Jul 2020, Solene Rapenne wrote:

> On Wed, 29 Jul 2020 09:36:38 -0600 (MDT)
> Austin Hook <[hidden email]>:
>
> > Probably got my packages messed up at some point, and should just stop
> > doing endless "upgrades", and start clean with 6.7, but for learning
> > purposes and perspective, would appreciate tips on why doing a pkg_add of
> > firefox under 6.6 would fail, while looking for a version of atk that that
> > is not in the packages for 6.6?
> >
> >
> > farm# pkg_add firefox
> > quirks-3.187 signed on 2020-05-19T14:41:48Z
> > Can't install firefox-72.0.2 because of libraries
> > |library atk-1.0.21809.3 not found
> > ...
> >
> > But looking at:
> >
> > https://ftp.openbsd.org/pub/OpenBSD/6.6/packages/amd64/
> >
> > I only see: atk-2.... and no atk-1....
> >
> > -------------------------- <clip> ----------------------
> > at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
> > atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
> > atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
> > atk-2.32.0.tgz               12-Oct-2019 06:06        461597
> > atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
> > atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
> > atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
> > --------------------------- </clip> -----------------------
> >
> > I realize that there are dependencies of dependencies going on here. but
> > for perspective, why wouldn't atk-1... exist in the same package
> > repository as the 6.6 version of firefox does, if that version (or
> > probably it's other dependencies) requires it.  Wouldn't package testing
> > have failed for firefox when it was tested for 6.6?  And if not, why not?
> >
> > Thanks in advance, for any comment.
> >
> > Austin Hook
>
> atk package contains the file
> /usr/local/lib/libatk-1.0.so.21809.3
>
> I don't know why pkg_add firefox doesn't work though, can you try
> pkg_add -U firefox or pkg_add -u && pkg_add firefox?
>
> Firefox 72.0.2 is the package pulled from package-stable and not
> the firefox version that came with 6.6 but it shouldn't fail.
>
> Looking at the package signature, the atk version matches
> the 6.6 atk package.
>
> Signature: firefox-72.0.2,5,@desktop-file-utils-0.24p0,
> @gtk+2-2.24.32p5,@gtk+3-3.24.12,@icu4c-64.2p0,
> @xdg-utils-1.1.3p1,X11-xcb.2.0,X11.17.0,Xcomposite.4.0,
> Xcursor.5.0,Xdamage.4.0,Xext.13.0,Xfixes.6.0,Xi.12.1,
> Xrender.6.0,Xt.11.0,atk-1.0.21809.3,c++.3.0,c++abi.1.0,c.95.1,
> cairo-gobject.2.0,cairo.13.0,fontconfig.13.0,freetype.30.0,
> gdk-3.2201.1,gdk-x11-2.0.2400.0,gdk_pixbuf-2.0.3200.1,
> gio-2.0.4200.9,glib-2.0.4201.2,gobject-2.0.4200.9,
> gthread-2.0.4200.9,gtk-3.2201.0,gtk-x11-2.0.2400.0,icudata.15.0,
> icui18n.15.0,icuuc.15.0,intl.6.0,m.10.1,pango-1.0.3800.2,
> pangocairo-1.0.3800.1,pangoft2-1.0.3800.1,pthread.26.1,
> sndio.7.0,xcb-shm.1.1,xcb.4.0,z.5.0
>

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Stefan Hagen-3
Austin Hook wrote:
> At one point the -u complains of a "loop" and asks me if I want to
> proceed anyway [n,y,a] so I select "a". After completion pkg_add -u
> the pkg_add firefox still fails.

Have you tried pkg_check?

Best Regards,
Stefan

--
Stefan Hagen | (gopher|https)://codevoid.de/0/gpg
CBD3 C468 64B4 6517 E8FB B90F B6BC 2EC5 52BE 43BA

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2
Here's the output of pkg_check

farm# pkg_check    
Packing-list sanity: ok
Direct dependencies: ok
--- gcj-4.9.4p12 -------------------
dependency lang/gcc/4.9,-main:gcc->=4.9,<4.10:gcc-4.9.4p12 does not match
any installed package
Reverse dependencies: ok
Files from packages: ok
--- python-2.7.15p0 -------------------
checksum for /usr/local/lib/python2.7/email/mime/__init__.pyc does not
match

I ran pkg_check twice, and get the same result.  

Not sure if anything there gives me a clue why I can't install firefox
(under 6.6).

However, I would appreciate any insight on how fix the things it is
complaining about.

For example, where is the checksum for

/usr/local/lib/python2.7/email/mime/__init__.pyc

the one that is not matching, to be found?

and how can I go grab the correct version of __init__.pyc from someplace?  
And what kind of checksum is being calculated?

I am hoping that I am only a few clues away from getting the feel for the
whole structure.  Sometimes wonder what balance one should take between
reading through miles of code and just begging for an island of insight.

Thanks!

Austin


On Wed, 29 Jul 2020, Stefan Hagen wrote:

> Austin Hook wrote:
> > At one point the -u complains of a "loop" and asks me if I want to
> > proceed anyway [n,y,a] so I select "a". After completion pkg_add -u
> > the pkg_add firefox still fails.
>
> Have you tried pkg_check?
>
> Best Regards,
> Stefan
>
> --
> Stefan Hagen | (gopher|https)://codevoid.de/0/gpg
> CBD3 C468 64B4 6517 E8FB B90F B6BC 2EC5 52BE 43BA
>

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Solene Rapenne
On Thu, 30 Jul 2020 09:32:53 -0600 (MDT)
Austin Hook <[hidden email]>:

> Here's the output of pkg_check
>
> farm# pkg_check    
> Packing-list sanity: ok
> Direct dependencies: ok
> --- gcj-4.9.4p12 -------------------
> dependency lang/gcc/4.9,-main:gcc->=4.9,<4.10:gcc-4.9.4p12 does not match
> any installed package
> Reverse dependencies: ok
> Files from packages: ok

gcj is non existent in 6.6, it was removed.  The removal reason
should be displayed as the last line of pkg_add -u output IIRC.

Are you sure you did run pkg_add -u and it worked correctly?

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Stuart Henderson
In reply to this post by austin
On 2020/07/29 09:36, Austin Hook wrote:

>
> Probably got my packages messed up at some point, and should just stop
> doing endless "upgrades", and start clean with 6.7, but for learning
> purposes and perspective, would appreciate tips on why doing a pkg_add of
> firefox under 6.6 would fail, while looking for a version of atk that that
> is not in the packages for 6.6?
>
>
> farm# pkg_add firefox
> quirks-3.187 signed on 2020-05-19T14:41:48Z
> Can't install firefox-72.0.2 because of libraries
> |library atk-1.0.21809.3 not found
> ...
>
> But looking at:
>
> https://ftp.openbsd.org/pub/OpenBSD/6.6/packages/amd64/
>
> I only see: atk-2.... and no atk-1....

atk-1.0.21809.3 reported by pkg_add in the "library not found" line refers
to the library version (file /usr/local/lib/libatk-1.0.so.21809.3) not the
package version (this library is contained in the atk-2.32.0 package).

>
> -------------------------- <clip> ----------------------
> at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
> atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
> atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
> atk-2.32.0.tgz               12-Oct-2019 06:06        461597
> atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
> atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
> atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
> --------------------------- </clip> -----------------------
>
> I realize that there are dependencies of dependencies going on here. but
> for perspective, why wouldn't atk-1... exist in the same package
> repository as the 6.6 version of firefox does, if that version (or
> probably it's other dependencies) requires it.  Wouldn't package testing
> have failed for firefox when it was tested for 6.6?  And if not, why not?
>
> Thanks in advance, for any comment.
>
> Austin Hook
>
>
>
>
>
>

Could you show the full output from these please?

echo $PKG_PATH
cat /etc/installurl
pkg_add -u
pkg_info

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2

Yes, I do believe the pkg_add -u is failing.  

For starters here is my current package source info.

=============================================
farm# echo $PKG_PATH      

farm# cat /etc/installurl                                                                                                              
https://cdn.openbsd.org/pub/OpenBSD
farm#
=============================================

However, at some point earlier I had used
#export PKG_PATH=http://ftp.vim.org/OpenBSD/6.6/packages/amd64/
[Now commented out in the .profile]

I had gotten behind in making updates, and so started using packages from
there.

My fault certainly.   But hoping I could recover, and in the process
learning a bit more about how the structure can get damaged, and hence
understand better how it all works.

Will have to run the full pkg_add -u, under current conditions, later
today, as I have to run across the border shortly.

If it becomes probable that I am wasting you folks time with too unique a
circumstance feel free to say so.

Meanwhile, I really appreciate such shared insights as helps my general
orientation.

Regards,

Austin
 




On Thu, 30 Jul 2020, Solene Rapenne wrote:

> On Thu, 30 Jul 2020 09:32:53 -0600 (MDT)
> Austin Hook <[hidden email]>:
>
> > Here's the output of pkg_check
> >
> > farm# pkg_check    
> > Packing-list sanity: ok
> > Direct dependencies: ok
> > --- gcj-4.9.4p12 -------------------
> > dependency lang/gcc/4.9,-main:gcc->=4.9,<4.10:gcc-4.9.4p12 does not match
> > any installed package
> > Reverse dependencies: ok
> > Files from packages: ok
>
> gcj is non existent in 6.6, it was removed.  The removal reason
> should be displayed as the last line of pkg_add -u output IIRC.
>
> Are you sure you did run pkg_add -u and it worked correctly?
>

On Thu, 30 Jul 2020, Stuart Henderson wrote:

> On 2020/07/29 09:36, Austin Hook wrote:
> >
> > Probably got my packages messed up at some point, and should just stop
> > doing endless "upgrades", and start clean with 6.7, but for learning
> > purposes and perspective, would appreciate tips on why doing a pkg_add of
> > firefox under 6.6 would fail, while looking for a version of atk that that
> > is not in the packages for 6.6?
> >
> >
> > farm# pkg_add firefox
> > quirks-3.187 signed on 2020-05-19T14:41:48Z
> > Can't install firefox-72.0.2 because of libraries
> > |library atk-1.0.21809.3 not found
> > ...
> >
> > But looking at:
> >
> > https://ftp.openbsd.org/pub/OpenBSD/6.6/packages/amd64/
> >
> > I only see: atk-2.... and no atk-1....
>
> atk-1.0.21809.3 reported by pkg_add in the "library not found" line refers
> to the library version (file /usr/local/lib/libatk-1.0.so.21809.3) not the
> package version (this library is contained in the atk-2.32.0 package).
> >
> > -------------------------- <clip> ----------------------
> > at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
> > atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
> > atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
> > atk-2.32.0.tgz               12-Oct-2019 06:06        461597
> > atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
> > atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
> > atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
> > --------------------------- </clip> -----------------------
> >
> > I realize that there are dependencies of dependencies going on here. but
> > for perspective, why wouldn't atk-1... exist in the same package
> > repository as the 6.6 version of firefox does, if that version (or
> > probably it's other dependencies) requires it.  Wouldn't package testing
> > have failed for firefox when it was tested for 6.6?  And if not, why not?
> >
> > Thanks in advance, for any comment.
> >
> > Austin Hook
> >
> >
> >
> >
> >
> >
>
> Could you show the full output from these please?
>
> echo $PKG_PATH
> cat /etc/installurl
> pkg_add -u
> pkg_info
>

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Vijay Sankar-3
Hi Austin,

I wanted to see if I could simulate your situation. Since I had a 6.6
-stable desktop,  I did a syspatch, upgraded that to 6.7, and then
encountered something very much like what you described when I did a
pkg_add -uUvVm.

Not completely sure why but I felt that spidermonkey update failure was
to blame for the firefox update failure so  anyways I did a pkd_add -uU
spidermonkey. This showed me that gnome-code-assistance-3.16.1p9 could
not be upgraded. So I just did a pkg_delete gnome-code-assistance, along
with mousetweaks-3.12.0p3, goffice08-0.8.17p7, and ruby25-dbus-0.11.1
since they all had come up as not required for 6.7. After that pkg_add
-uUvVm upgraded ALL the packages. Also noticed that atk-2.30 on 6.6 to
was upgraded to atk-2.34.1p1 on 6.7.

Hope this is useful info. If there is any benefit in sending my
/var/log/messages that show all the package additions and deletions,
please let me know as well. Have a nice day,

Vijay


On 2020-07-30 13:13, Austin Hook wrote:

> Yes, I do believe the pkg_add -u is failing.
>
> For starters here is my current package source info.
>
> =============================================
> farm# echo $PKG_PATH
>
> farm# cat /etc/installurl
> https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fcdn.openbsd.org%2Fpub%2FOpenBSD&amp;data=02%7C01%7C%7C91f1b235ffd046b4552808d834b46c28%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637317296792770540&amp;sdata=UoLJoGl8t%2BlhsDh1XZXw9mOlbUrTonvE6dXZmqVIZUM%3D&amp;reserved=0
> farm#
> =============================================
>
> However, at some point earlier I had used
> #export PKG_PATH=https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fftp.vim.org%2FOpenBSD%2F6.6%2Fpackages%2Famd64%2F&amp;data=02%7C01%7C%7C91f1b235ffd046b4552808d834b46c28%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637317296792770540&amp;sdata=jLStPMDbuf8k8lURsnbRttz9rgyarfcbnz0Cd78tEsk%3D&amp;reserved=0
> [Now commented out in the .profile]
>
> I had gotten behind in making updates, and so started using packages from
> there.
>
> My fault certainly.   But hoping I could recover, and in the process
> learning a bit more about how the structure can get damaged, and hence
> understand better how it all works.
>
> Will have to run the full pkg_add -u, under current conditions, later
> today, as I have to run across the border shortly.
>
> If it becomes probable that I am wasting you folks time with too unique a
> circumstance feel free to say so.
>
> Meanwhile, I really appreciate such shared insights as helps my general
> orientation.
>
> Regards,
>
> Austin
>  
>
>
>
>
> On Thu, 30 Jul 2020, Solene Rapenne wrote:
>
>> On Thu, 30 Jul 2020 09:32:53 -0600 (MDT)
>> Austin Hook <[hidden email]>:
>>
>>> Here's the output of pkg_check
>>>
>>> farm# pkg_check
>>> Packing-list sanity: ok
>>> Direct dependencies: ok
>>> --- gcj-4.9.4p12 -------------------
>>> dependency lang/gcc/4.9,-main:gcc->=4.9,<4.10:gcc-4.9.4p12 does not match
>>> any installed package
>>> Reverse dependencies: ok
>>> Files from packages: ok
>> gcj is non existent in 6.6, it was removed.  The removal reason
>> should be displayed as the last line of pkg_add -u output IIRC.
>>
>> Are you sure you did run pkg_add -u and it worked correctly?
>>
> On Thu, 30 Jul 2020, Stuart Henderson wrote:
>
>> On 2020/07/29 09:36, Austin Hook wrote:
>>> Probably got my packages messed up at some point, and should just stop
>>> doing endless "upgrades", and start clean with 6.7, but for learning
>>> purposes and perspective, would appreciate tips on why doing a pkg_add of
>>> firefox under 6.6 would fail, while looking for a version of atk that that
>>> is not in the packages for 6.6?
>>>
>>>
>>> farm# pkg_add firefox
>>> quirks-3.187 signed on 2020-05-19T14:41:48Z
>>> Can't install firefox-72.0.2 because of libraries
>>> |library atk-1.0.21809.3 not found
>>> ...
>>>
>>> But looking at:
>>>
>>> https://nam10.safelinks.protection.outlook.com/?url=https%3A%2F%2Fftp.openbsd.org%2Fpub%2FOpenBSD%2F6.6%2Fpackages%2Famd64%2F&amp;data=02%7C01%7C%7C91f1b235ffd046b4552808d834b46c28%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637317296792770540&amp;sdata=E%2F4Ryl17kjd%2FF%2BQoCD7pKZm%2BMVmNUIzb1YizcLLgvm4%3D&amp;reserved=0
>>>
>>> I only see: atk-2.... and no atk-1....
>> atk-1.0.21809.3 reported by pkg_add in the "library not found" line refers
>> to the library version (file /usr/local/lib/libatk-1.0.so.21809.3) not the
>> package version (this library is contained in the atk-2.32.0 package).
>>> -------------------------- <clip> ----------------------
>>> at-spi2-core-2.32.1.tgz      12-Oct-2019 06:06        258681
>>> atari800-4.1.0.tgz           12-Oct-2019 06:06        408617
>>> atf-0.18p3.tgz               12-Oct-2019 06:06       1129085
>>> atk-2.32.0.tgz               12-Oct-2019 06:06        461597
>>> atk2mm-2.28.0.tgz            12-Oct-2019 06:06       1238387
>>> atlas-0.4.3.1p10.tgz         12-Oct-2019 06:06       2360270
>>> atomicparsley-0.9.6p3.tgz    12-Oct-2019 06:06        138835
>>> --------------------------- </clip> -----------------------
>>>
>>> I realize that there are dependencies of dependencies going on here. but
>>> for perspective, why wouldn't atk-1... exist in the same package
>>> repository as the 6.6 version of firefox does, if that version (or
>>> probably it's other dependencies) requires it.  Wouldn't package testing
>>> have failed for firefox when it was tested for 6.6?  And if not, why not?
>>>
>>> Thanks in advance, for any comment.
>>>
>>> Austin Hook
>>>
>>>
>>>
>>>
>>>
>>>
>> Could you show the full output from these please?
>>
>> echo $PKG_PATH
>> cat /etc/installurl
>> pkg_add -u
>> pkg_info
>>

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2
Hi Vijay,
   Nice to hear from you too -- and it's been a while.  I think your test
- experience is quite useful, and your synopsis is encouraging.  No need
to send all the gory details.

   I was a bit afraid to mess around too much with the machine I do most
of my work at home on.  I had tried deleting some packages that were
working, and then couldn't re-install them, which put me onto using
Chrome, and missing my customized Firefox environment.

   But it is time I learned the packaging environment a bit better, so
it's interesting to try to patch together the pieces without just starting
fresh.  I guess I'll save my bookmarks and some other rarely backed up
stuff on a PassPort drive, (most any other precious code and data I
I have is shared with a handful of servers elsewhere on a personal
cvs).

  Then I can go wild with some of those pkg_add options I have never
played with before.   Before, if necessary, a big restart with 6.7, which
I'll get to shortly anyway.

  Stuart suggested sending the entire pkg_add -u" output for a quick scan
of my foolishness, so I an including it at the bottom of this email --
lines chopped at character 78, because all the linking stuff makes it half
a megabyte, which seems excessive to burden the archives with.   Maybe
seeing the full link into is not necessary to allow one more comment if
any of you folks care to peek at my pkg_add -u output.

  Elsewise, I shall leave the ports mailing list to the more technical and
serious stuff.

See:  pkg_add -u  at the very end of this email  --->


On Thu, 30 Jul 2020, Vijay Sankar wrote:

> Hi Austin,
>
> I wanted to see if I could simulate your situation. Since I had a 6.6 -stable
> desktop,  I did a syspatch, upgraded that to 6.7, and then encountered
> something very much like what you described when I did a pkg_add -uUvVm.
>
> Not completely sure why but I felt that spidermonkey update failure was to
> blame for the firefox update failure so  anyways I did a pkd_add -uU
> spidermonkey. This showed me that gnome-code-assistance-3.16.1p9 could not be
> upgraded. So I just did a pkg_delete gnome-code-assistance, along with
> mousetweaks-3.12.0p3, goffice08-0.8.17p7, and ruby25-dbus-0.11.1 since they
> all had come up as not required for 6.7. After that pkg_add -uUvVm upgraded
> ALL the packages. Also noticed that atk-2.30 on 6.6 to was upgraded to
> atk-2.34.1p1 on 6.7.
>
> Hope this is useful info. If there is any benefit in sending my
> /var/log/messages that show all the package additions and deletions, please
> let me know as well. Have a nice day,
>
> Vijay
>

Script started on Thu Jul 30 20:02:49 2020
farm# pkg_add -u
quirks-3.187 signed on 2020-05-19T14:41:48Z
|No change in quirks-3.187Checking packages|No change in AsteriskGuide
| Dependencies of py-libxml-2.9.8 on libxml-=2.9.8 don't match
Merging py-libxml-2.9.8->2.9.9 (ok)
Checking packages|No change in libffi-3.2.1p5gettext-0.19.8.1p1->ge
| Dependencies of python-3.6.6p1 on gettext-* don't match
| Dependencies of recode-3.6p11 on gettext-* don't match
| Dependencies of gstreamer-0.10.36p12 on gettext-* don't match
| Dependencies of vlc-2.2.8p2 on gettext-* don't match
| Dependencies of nano-3.1 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of gnuplot-5.2.4 on gettext-* don't match
| Dependencies of gmake-4.2.1 on gettext-* don't match
| Dependencies of libgpg-error-1.32 on gettext-* don't match
| Dependencies of gettext-tools-0.19.8.1 on gettext-* don't match
| Dependencies of git-2.19.1 on gettext-* don't match
| Dependencies of rxvt-unicode-9.22p6 on gettext-* don't match
| Dependencies of gsed-4.2.2p1 on gettext-* don't match
| Dependencies of popt-1.16p1 on gettext-* don't match
| Dependencies of tnef-1.4.12p0 on gettext-* don't match
| Dependencies of wxWidgets-gtk2-2.8.12p16 on gettext-* don't match
| Dependencies of lyx-2.2.3p2 on gettext-* don't match
| Dependencies of e2fsprogs-1.42.12p4 on gettext-* don't match
| Dependencies of p11-kit-0.23.2p1 on gettext-* don't match
| Dependencies of a2ps-4.14p14 on gettext-* don't match
| Dependencies of poppler-0.59.0 on gettext-* don't match
| Dependencies of bash-4.4.23 on gettext-* don't match
| Dependencies of aspell-0.60.6.1p6 on gettext-* don't match
| Dependencies of libidn-1.35 on gettext-* don't match
| Dependencies of vim-8.1.0438-gtk2 on gettext-* don't match
| Dependencies of inkscape-0.92.3p3 on gettext-* don't match
| Dependencies of gdbm-1.16 on gettext-* don't match
| Dependencies of python-2.7.15p0 on gettext-* don't match
| Dependencies of libksba-1.3.5p1 on gettext-* don't match
| Dependencies of mailutil-uw-2.21v0 on gettext-* don't match
| Dependencies of coreutils-8.30 on gettext-* don't match
| Dependencies of glib2-2.56.3p0 on gettext-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of alpine-2.21p0 on gettext-* don't match
| Dependencies of wget-1.19.5 on gettext-* don't match
| Dependencies of dos2unix-7.4.0 on gettext-* don't match
| Dependencies of libexif-0.6.21p1 on gettext-* don't match
| Dependencies of calibre-2.85.1p7 on gettext-* don't match
| Dependencies of qtbase-5.9.6p1 on gettext-* don't match
| Dependencies of gnupg-2.2.10 on gettext-* don't match
| Dependencies of pico-5.09 on gettext-* don't match
| Dependencies of clisp-2.49p2 on gettext-* don't match
| Dependencies of gnupg-1.4.23 on gettext-* don't match
| Dependencies of gtar-1.30p0 on gettext-* don't match
Merging python-3.6.6p1->3.6.9 (ok)
Merging recode-3.6p11->3.6p12 (ok)
Merging gstreamer-0.10.36p12->0.10.36p13 (ok)
Merging vlc-2.2.8p2->2.2.8p7 (ok)
Merging nano-3.1->4.4 (ok)
Checking packages|No need to update python-3.4.5NOT MERGING: can't
Merging gnuplot-5.2.4->5.2.5p1 (ok)
Merging gmake-4.2.1->4.2.1p4 (ok)
Merging libgpg-error-1.32->1.36p0 (ok)
Merging gettext-tools-0.19.8.1->0.20.1p2 (ok)
Merging git-2.19.1->2.24.2 (ok)
Merging rxvt-unicode-9.22p6->9.22p10 (ok)
Merging gsed-4.2.2p1->4.2.2p3 (ok)
Merging popt-1.16p1->1.16p2 (ok)
Merging tnef-1.4.12p0->1.4.12p1 (ok)
Merging wxWidgets-gtk2-2.8.12p16->wxWidgets-gtk3-3.0.4p2 (ok)
Merging lyx-2.2.3p2->2.3.2p1 (ok)
Merging e2fsprogs-1.42.12p4->1.42.12p5 (ok)
Merging p11-kit-0.23.2p1->0.23.18.1 (ok)
Merging a2ps-4.14p14->4.14p15 (ok)
Merging poppler-0.59.0->0.81.0 (ok)
Merging bash-4.4.23->5.0.11 (ok)
Merging aspell-0.60.6.1p6->0.60.6.1p10 (ok)
Merging libidn-1.35->1.35p0 (ok)
Merging vim-8.1.0438-gtk2->8.1.2061-gtk2 (ok)
Merging inkscape-0.92.3p3->0.92.4p1 (ok)
Merging gdbm-1.16->1.18.1p0 (ok)
Merging python-2.7.15p0->2.7.16p1 (ok)
Merging libksba-1.3.5p1->1.3.5p2 (ok)
Merging mailutil-uw-2.21v0->2.21p3v0 (ok)
Merging coreutils-8.30->8.31p1 (ok)
Merging glib2-2.56.3p0->2.60.7p0 (ok)
Checking packages|No need to update python-3.5.2NOT MERGING: can't
Merging alpine-2.21p0->2.21p3 (ok)
Merging wget-1.19.5->1.20.3p1 (ok)
Merging dos2unix-7.4.0->7.4.0p0 (ok)
Merging libexif-0.6.21p1->0.6.21p2 (ok)
Merging calibre-2.85.1p7->2.85.1p10 (ok)
Merging qtbase-5.9.6p1->5.9.7p6 (ok)
Merging gnupg-2.2.10->2.2.12p0 (ok)
Merging pico-5.09->5.09p20 (ok)
Merging clisp-2.49p2->2.49p4 (ok)
Merging gnupg-1.4.23->1.4.23p3 (ok)
Merging gtar-1.30p0->1.32p1 (ok)
Proceed with update anyway ? [y/N/a] y
Detected loop, merging sets ok
| py-qt5-5.9p2->5.9p4
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
Detected loop, merging sets ok
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
| py-sip-4.19.3p2->4.19.17
Detected loop, merging sets ok
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
| py-setuptools-40.0.0v0->41.0.0p0v0
Detected loop, merging sets ok
| py-lxml-3.7.0p0->4.3.3p1
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
Detected loop, merging sets ok
| py-mechanize-0.3.5->0.3.5
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+libxml-2.9.8p0+py-libxml-2.9.8->libxml+py-libxml-2.9.9
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
| libbluray-1.0.0p0->1.0.0p0
Checking packages|No change in libcddb-1.3.2p0gcc-libs-4.9.4p12->8.
| Dependencies of pdftk-2.02p3 on gcc-libs->=4.9,<4.10 don't match
| Dependencies of lapack-3.7.1 on gcc-libs->=4.9,<4.10 don't match
| Dependencies of libcerf-1.5 on gcc-libs->=4.9,<4.10 don't match
| Dependencies of blas-3.7.1 on gcc-libs->=4.9,<4.10 don't match
| Dependencies of py-numpy-1.14.5p0 on gcc-libs->=4.9,<4.10 don't match
| Dependencies of py3-numpy-1.14.5p0 on gcc-libs->=4.9,<4.10 don't match
Merging pdftk-2.02p3->3.0.3p0 (ok)
Merging lapack-3.7.1->3.8.0p1 (ok)
Merging libcerf-1.5->1.11p0 (ok)
Merging blas-3.7.1->3.8.0p0 (ok)
Merging py-numpy-1.14.5p0->1.14.6p1 (ok)
Merging py3-numpy-1.14.5p0->1.14.6p1 (ok)
Detected loop, merging sets ok
| python-3.7.4
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
| blas-3.7.1+gcc-libs-4.9.4p12+lapack-3.7.1+libcerf-1.5+pdftk-2.02p3+py-numpy-
Checking packages|No change in libexecinfo-0.3p2v0Detected loop, me
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
| libgcrypt-1.8.3->1.8.5
Detected loop, merging sets ok
| py-beautifulsoup-3.2.1->3.2.1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
Checking packages|No change in curl-7.66.0No change in nghttp2-1.3
| gdk-pixbuf-2.36.12->2.38.2
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
| gtk-update-icon-cache-3.22.30p1->3.24.12
Detected loop, merging sets ok
| glib2mm-2.56.0p1->2.60.1p0
| atk2mm-2.24.2p2->2.28.0
| gtk2mm-2.24.5p1->2.24.5p2
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23
Checking packages|No change in libsigc++-2.10.2Detected loop, mergi
| enchant-1.6.1p1->1.6.1p1
| gtkspell-2.0.16p11->2.0.16p13
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Checking packages|No change in hunspell-1.6.2p0No change in mozill
| shared-mime-info-1.10p4->1.10p5
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Detected loop, merging sets ok
| py-xml-0.8.4p14->0.8.4p14
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Detected loop, merging sets ok
| pango-1.42.4p0->1.42.4p3
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Checking packages|No change in graphite2-1.3.13p0Detected loop, mer
| cairo-1.15.12->1.16.0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
| harfbuzz-1.9.0->2.6.2
Checking packages|No change in icu4c-64.2p0No change in libxkbcomm
| libxslt-1.1.32->1.1.33
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Detected loop, merging sets ok
| pangomm-2.40.1p1->2.42.0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Checking packages|No change in pcre-8.41p2No change in pcre2-10.34
| libassuan-2.5.1p0->2.5.1p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Detected loop, merging sets ok
| desktop-file-utils-0.23p9->0.24p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Checking packages|No change in libsigsegv-2.12No change in libtar-
| avahi-0.7p4->0.7p6
| cups-libs-2.2.8p0->2.3.0p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Checking packages|No change in libdaemon-0.14p1No change in dbus-d
| at-spi2-core-2.28.0p0->2.32.1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+atk2mm-2.24
Detected loop, merging sets ok
| atk-2.28.1->2.32.0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Detected loop, merging sets ok
| py-apsw-3.9.2->3.9.2p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Checking packages|No change in p5-Error-0.17025Detected loop, mergi
| py-netifaces-0.10.7->0.10.9p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Checking packages|No change in jasper-2.0.14No change in javaPathH
| enchant2-2.2.3->2.2.7
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Checking packages|No change in openjp2-2.3.1No change in opus-1.3.
| gtk+2-2.24.32p2->2.24.32p5
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
| gnome-icon-theme-symbolic-3.12.0p3->3.12.0p3
| gnome-icon-theme-3.12.0p5->3.12.0p5
Detected loop, merging sets ok
| gtk+3-3.22.30p4->3.24.12
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
| dconf-0.28.0p1->0.32.0p0
Detected loop, merging sets ok
| at-spi2-atk-2.26.2->2.32.0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-cor
Detected loop, merging sets ok
| gnutls-3.5.19->3.6.10p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in libidn2-2.3.0No change in libunistr
| py-cssselect-1.0.0p0->1.0.0p2
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| py-cssutils-1.0.2->1.0.2p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| py-dateutil-2.7.3->2.8.0p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| py-six-1.11.0->1.12.0p1
Checking packages|No change in libraw-0.19.5Detected loop, merging
| librsvg-2.44.6p0->2.46.4
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| libcroco-0.6.12->0.6.13
Detected loop, merging sets ok
| pinentry-1.1.0p0->1.1.0p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| libsecret-0.18.6->0.18.8p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| podofo-0.9.5p0->0.9.5p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in poppler-data-0.4.9Detected loop, mer
| qtsensors-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtserialport-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtsvg-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qttools-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtwebchannel-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtwebkit-5.9.0p6->5.9.0p9
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| qtlocation-5.9.7p0
Detected loop, merging sets ok
| gstreamer1-1.14.4->1.16.1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| gstreamer1-plugins-base-1.14.4->1.16.1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in libarchive-3.4.0No change in zstd-1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| gvfs-1.36.2p1->1.40.2
| libsoup-2.62.3->2.66.3
| glib2-networking-2.56.1p0->2.60.3
Checking packages|No change in cdparanoia-3.a9.8p4No change in orc
| gcr-3.28.0p3->3.28.1p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| graphene-1.8.2p0->1.10.0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtwebsockets-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtdeclarative-5.9.7p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| py3-setuptools-40.0.0v0->41.0.0p0v0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in ffcall-1.10p4Detected loop, merging
| ffmpeg-2.8.15v0->4.2.1p0v0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in dav1d-0.4.0No change in aom-1.0.0.2
| libnotify-0.7.7->0.7.8
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| geoclue-0.12.99p7->0.12.99p9
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| dbus-glib-0.110v0->0.110p1v0
Detected loop, merging sets ok
| qtx11extras-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtxmlpatterns-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in readline-7.0p0Detected loop, merging
| qt4-4.8.7p17->4.8.7p19
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in libmng-1.0.10p3No change in lcms-1.
| qtconnectivity-5.9.6->5.9.7p0
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| qtmultimedia-5.9.6->5.9.7p1
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in openal-1.19.1v0No change in libbs2b
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| gstreamer1-plugins-bad-1.14.4->1.16.1
| libmms-0.6.2p4->0.6.2p4
Detected loop, merging sets ok
| gstreamer1mm-1.10.0p0->1.10.0p3
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| py-dbus-1.2.8->1.2.12
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in py-dbus-common-1.2.12Detected loop,
| py-dnspython-1.15.0->1.16.0p2
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Checking packages|No change in taglib-1.11.1p3Detected loop, mergin
| texlive_base-2017p3->2018p3
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
Detected loop, merging sets ok
| .libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+at-spi2-atk
| harfbuzz-icu-1.9.0->2.6.2
Checking packages|No change in zziplib-0.13.62p1No change in detex
| ghostscript-9.07p7->9.07p7
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspel
Checking packages|No change in jbig2dec-0.11No change in ghostscri
| ImageMagick-6.9.10.10p1->6.9.10.62
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+a2ps-4.14p14+alpine-2.21p0+aspel
Detected loop, merging sets ok
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
| djvulibre-3.5.27p4->3.5.27p6
Checking packages|No change in jbigkit-2.1No change in fftw3-3.3.8
| adwaita-icon-theme-3.28.0p1->3.32.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Detected loop, merging sets ok
| poppler-qt5-0.59.0->0.81.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Detected loop, merging sets ok
| poppler-utils-0.59.0->0.81.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in potrace-1.15Detected loop, merging s
| ps2eps-1.68p0->1.68p0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in boehm-gc-7.6.0p3No change in boost-
| cairomm-1.12.2p1->1.12.2p1
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in soundtouch-2.1.2No change in speex-
| libproxy-0.4.15p0->0.4.15p4
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Detected loop, merging sets ok
| libpsl-0.17.0->0.20.2p0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in psutils-1.23Detected loop, merging s
| pulseaudio-12.2->13.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in spidermonkey-60.8.0p0v1No change in
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
| polkit-0.115->0.116p0
| consolekit2-1.2.1p0->1.2.1p8
Checking packages|No change in libltdl-2.4.2p1Detected loop, mergin
| tdb-1.3.16->1.3.16p0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Detected loop, merging sets ok
| py-CherryPy-3.2.2p0->3.2.2p0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Detected loop, merging sets ok
| py-Pillow-5.1.0->6.1.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in ijs-0.35p3No change in iodbc-3.52.1
| gsettings-desktop-schemas-3.28.1->3.32.0
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No change in gsl-1.15p3No change in gsm-1.0.18[
| gstreamer-plugins-base-0.10.36p19->0.10.36p19
| .libs-texlive_base-2015+.libs1-libxml-2.9.5+ImageMagick-6.9.10.10p1+a2ps-4.1
Checking packages|No need to update python-3.5.2No need to update
| Dependencies of py-wxPython-2.8.12.0p4 on wxWidgets-gtk2->=2.8.12 don't matc
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of cups-2.2.8p1 on cups-libs-=2.2.8 don't match
| Dependencies of texlive_texmf-minimal-2017p2 on texlive_base-2017p3,texlive_
| Dependencies of gtk+3-cups-3.22.30p0 on gtk+3-=3.22.30 don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of python-tkinter-2.7.15p0 on python-2.7.15p0 don't match
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of audacity-1.3.9p12 on wxWidgets-gtk2->=2.8.6 don't match
Merging py-wxPython-2.8.12.0p4->3.0.2.0p0 (ok)
Merging cups-2.2.8p1->2.3.0p3 (ok)
Merging texlive_texmf-minimal-2017p2->2018p1 (ok)
Merging gtk+3-cups-3.22.30p0->3.24.12 (ok)
Merging python-tkinter-2.7.15p0->2.7.16 (ok)
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Merging audacity-1.3.9p12->2.3.2 (ok)
Proceed with update anyway ? [y/N/a] a
Checking packages|No change in libsoxr-0.1.3Detected loop, merging
| colord-1.3.5p1->1.3.5p1
| [python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cairo-1.14.12+.l
Detected loop, merging sets ok
| cups-filters-1.21.3->1.25.6
| [python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cairo-1.14.12+.l
Detected loop, merging sets ok
| mupdf-1.13.0p2->1.16.1p0
| [python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cairo-1.14.12+.l
Checking packages|No change in libmad-0.15.1bp6Detected loop, mergi
| foomatic-db-engine-4.0.13p0->4.0.13p1
| [python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cairo-1.14.12+.l
Checking packages|No change in p5-DBI-1.641No change in p5-PlRPC-0
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of texlive_texmf-full-2017p2 on texlive_texmf-minimal-2017p2 do
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
Merging texlive_texmf-full-2017p2->2018 (ok)
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
[python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cairo-1.14.12+.lib
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Can't install [python-3.4.5+python-3.5.2].libs-ImageMagick-6.9.4.10+.libs-cair
.libs-texlive_base-2015+texlive_texmf-buildset-2017p2->texlive_texmf-buildset-
| Dependencies of texlive_texmf-minimal-2017p2 on texlive_texmf-buildset-2017p
| Dependencies of texlive_base-2017p3 on texlive_texmf-buildset-2017 don't mat
Merging texlive_texmf-minimal-2017p2->2018p1 (ok)
Merging texlive_base-2017p3->2018p3 (ok)
.libs-texlive_base-2015+texlive_base-2017p3+texlive_texmf-buildset-2017p2+texl
| Dependencies of texlive_texmf-full-2017p2 on texlive_texmf-minimal-2017p2 do
Merging texlive_texmf-full-2017p2->2018 (ok)
Can't install .libs-texlive_base-2015+texlive_base-2017p3+texlive_texmf-builds
Checking packages|No change in transfig-3.2.6No change in netpbm-1
|library avcodec.23.0 not found
| /usr/local/lib/libavcodec.so.22.2 (ffmpeg-2.8.15v0): bad major
|library avformat.20.0 not found
| /usr/local/lib/libavformat.so.19.4 (ffmpeg-2.8.15v0): bad major
|library avutil.13.0 not found
| /usr/local/lib/libavutil.so.12.4 (ffmpeg-2.8.15v0): bad major
|library swscale.7.0 not found
| /usr/local/lib/libswscale.so.6.1 (ffmpeg-2.8.15v0): bad major
Direct dependencies for .libs-openimageio-1.5.20p1+.libs1-openimageio-1.6.16p0
Full dependency tree is ffmpeg-2.8.15v0 opencolorio-20140911p2 python-2.7.15p0
gettext-0.19.8.1p1->gettext-runtime-0.20.1p0 forward dependencies:
| Dependencies of e2fsprogs-1.42.12p4 on gettext-* don't match
| Dependencies of p11-kit-0.23.2p1 on gettext-* don't match
| Dependencies of gsed-4.2.2p1 on gettext-* don't match
| Dependencies of rxvt-unicode-9.22p6 on gettext-* don't match
| Dependencies of gettext-tools-0.19.8.1 on gettext-* don't match
| Dependencies of nano-3.1 on gettext-* don't match
| Dependencies of vlc-2.2.8p2 on gettext-* don't match
| Dependencies of gnuplot-5.2.4 on gettext-* don't match
| Dependencies of recode-3.6p11 on gettext-* don't match
| Dependencies of python-3.6.6p1 on gettext-* don't match
| Dependencies of gtar-1.30p0 on gettext-* don't match
| Dependencies of clisp-2.49p2 on gettext-* don't match
| Dependencies of gnupg-1.4.23 on gettext-* don't match
| Dependencies of libexif-0.6.21p1 on gettext-* don't match
| Dependencies of qtbase-5.9.6p1 on gettext-* don't match
| Dependencies of dos2unix-7.4.0 on gettext-* don't match
| Dependencies of wget-1.19.5 on gettext-* don't match
| Dependencies of python-2.7.15p0 on gettext-* don't match
| Dependencies of mailutil-uw-2.21v0 on gettext-* don't match
| Dependencies of libidn-1.35 on gettext-* don't match
| Dependencies of bash-4.4.23 on gettext-* don't match
| Dependencies of wxWidgets-gtk2-2.8.12p16 on gettext-* don't match
| Dependencies of tnef-1.4.12p0 on gettext-* don't match
| Dependencies of lyx-2.2.3p2 on gettext-* don't match
| Dependencies of popt-1.16p1 on gettext-* don't match
| Dependencies of git-2.19.1 on gettext-* don't match
| Dependencies of gmake-4.2.1 on gettext-* don't match
| Dependencies of libgpg-error-1.32 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of gstreamer-0.10.36p12 on gettext-* don't match
| Dependencies of gnupg-2.2.10 on gettext-* don't match
| Dependencies of pico-5.09 on gettext-* don't match
| Dependencies of calibre-2.85.1p7 on gettext-* don't match
| Dependencies of alpine-2.21p0 on gettext-* don't match
| Dependencies of glib2-2.56.3p0 on gettext-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of libksba-1.3.5p1 on gettext-* don't match
| Dependencies of coreutils-8.30 on gettext-* don't match
| Dependencies of gdbm-1.16 on gettext-* don't match
| Dependencies of inkscape-0.92.3p3 on gettext-* don't match
| Dependencies of vim-8.1.0438-gtk2 on gettext-* don't match
| Dependencies of aspell-0.60.6.1p6 on gettext-* don't match
| Dependencies of poppler-0.59.0 on gettext-* don't match
| Dependencies of a2ps-4.14p14 on gettext-* don't match
Merging e2fsprogs-1.42.12p4->1.42.12p5 (ok)
Merging p11-kit-0.23.2p1->0.23.18.1 (ok)
Merging gsed-4.2.2p1->4.2.2p3 (ok)
Merging rxvt-unicode-9.22p6->9.22p10 (ok)
Merging gettext-tools-0.19.8.1->0.20.1p2 (ok)
Merging nano-3.1->4.4 (ok)
Merging vlc-2.2.8p2->2.2.8p7 (ok)
Merging gnuplot-5.2.4->5.2.5p1 (ok)
Merging recode-3.6p11->3.6p12 (ok)
Merging python-3.6.6p1->3.6.9 (ok)
Merging gtar-1.30p0->1.32p1 (ok)
Merging clisp-2.49p2->2.49p4 (ok)
Merging gnupg-1.4.23->1.4.23p3 (ok)
Merging libexif-0.6.21p1->0.6.21p2 (ok)
Merging qtbase-5.9.6p1->5.9.7p6 (ok)
Merging dos2unix-7.4.0->7.4.0p0 (ok)
Merging wget-1.19.5->1.20.3p1 (ok)
Merging python-2.7.15p0->2.7.16p1 (ok)
Merging mailutil-uw-2.21v0->2.21p3v0 (ok)
Merging libidn-1.35->1.35p0 (ok)
Merging bash-4.4.23->5.0.11 (ok)
Merging wxWidgets-gtk2-2.8.12p16->wxWidgets-gtk3-3.0.4p2 (ok)
Merging tnef-1.4.12p0->1.4.12p1 (ok)
Merging lyx-2.2.3p2->2.3.2p1 (ok)
Merging popt-1.16p1->1.16p2 (ok)
Merging git-2.19.1->2.24.2 (ok)
Merging gmake-4.2.1->4.2.1p4 (ok)
Merging libgpg-error-1.32->1.36p0 (ok)
Checking packages|No need to update python-3.4.5NOT MERGING: can't
Merging gstreamer-0.10.36p12->0.10.36p13 (ok)
Merging gnupg-2.2.10->2.2.12p0 (ok)
Merging pico-5.09->5.09p20 (ok)
Merging calibre-2.85.1p7->2.85.1p10 (ok)
Merging alpine-2.21p0->2.21p3 (ok)
Merging glib2-2.56.3p0->2.60.7p0 (ok)
Checking packages|No need to update python-3.5.2NOT MERGING: can't
Merging libksba-1.3.5p1->1.3.5p2 (ok)
Merging coreutils-8.30->8.31p1 (ok)
Merging gdbm-1.16->1.18.1p0 (ok)
Merging inkscape-0.92.3p3->0.92.4p1 (ok)
Merging vim-8.1.0438-gtk2->8.1.2061-gtk2 (ok)
Merging aspell-0.60.6.1p6->0.60.6.1p10 (ok)
Merging poppler-0.59.0->0.81.0 (ok)
Merging a2ps-4.14p14->4.14p15 (ok)
Detected loop, merging sets ok
| a2ps-4.14p14+alpine-2.21p0+aspell-0.60.6.1p6+bash-4.4.23+calibre-2.85.1p7+cl
| python-3.7.4
Checking packages|No need to update python-3.5.2No need to update
| Dependencies of py-wxPython-2.8.12.0p4 on wxWidgets-gtk2->=2.8.12 don't matc
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of python-tkinter-2.7.15p0 on python-2.7.15p0 don't match
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of audacity-1.3.9p12 on wxWidgets-gtk2->=2.8.6 don't match
Merging py-wxPython-2.8.12.0p4->3.0.2.0p0 (ok)
Merging python-tkinter-2.7.15p0->2.7.16 (ok)
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Merging audacity-1.3.9p12->2.3.2 (ok)
[python-3.4.5+python-3.5.2].libs-glib2-2.54.3p1+.libs-libidn-1.33p0+.libs1-gdb
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Can't install [python-3.4.5+python-3.5.2].libs-glib2-2.54.3p1+.libs-libidn-1.3
Can't install blender-2.79p1->2.79p7: can't resolve python-3.7.4
Checking packages|No change in brotli-1.0.7No change in cdk-5.0.20
|library atk-1.0.21809.3 not found
| /usr/local/lib/libatk-1.0.so.21809.2 (atk-2.28.1): minor is too small
|library gio-2.0.4200.9 not found
| /usr/local/lib/libgio-2.0.so.4200.7 (glib2-2.56.3p0): minor is too small
|library glib-2.0.4201.2 not found
| /usr/local/lib/libglib-2.0.so.4201.0 (glib2-2.56.3p0): minor is too small
|library gmodule-2.0.4200.9 not found
| /usr/local/lib/libgmodule-2.0.so.4200.7 (glib2-2.56.3p0): minor is too small
|library gobject-2.0.4200.9 not found
| /usr/local/lib/libgobject-2.0.so.4200.7 (glib2-2.56.3p0): minor is too small
|library gthread-2.0.4200.9 not found
| /usr/local/lib/libgthread-2.0.so.4200.7 (glib2-2.56.3p0): minor is too small
|library harfbuzz.15.0 not found
| /usr/local/lib/libharfbuzz.so.12.1 (harfbuzz-1.9.0): bad major
Direct dependencies for libglade2-2.6.4p16v0->2.6.4p17v0 resolve to libxml-2.9
Full dependency tree is glib2-2.56.3p0 pango-1.42.4p0 python-2.7.15p0 cairo-1.
Checking packages|No change in py-cairo-1.18.1p0Can't install py-go
|library glib-2.0.4201.2 not found
| /usr/local/lib/libglib-2.0.so.4200.6 (.libs-glib2-2.54.3p1): bad major
| /usr/local/lib/libglib-2.0.so.4201.0 (glib2-2.56.3p0): minor is too small
Direct dependencies for py-gobject-2.28.7v0->2.28.7v0 resolve to glib2-2.56.3p
Full dependency tree is libelf-0.8.13p4 python-2.7.15p0 glib2-2.56.3p0 gettext
Can't install py-gtk2-2.24.0p6 because of libraries
Direct dependencies for py-gtk2-2.24.0p5->2.24.0p6 resolve to py-numpy-1.14.5p
Full dependency tree is jpeg-2.0.3v0 lapack-3.7.1 .libs-libiconv-1.14p3 .libs-
Can't install libgnome-keyring-3.12.0p6 because of libraries
|library gpg-error.3.19 not found
| /usr/local/lib/libgpg-error.so.3.16 (libgpg-error-1.32): minor is too small
Direct dependencies for libgnome-keyring-3.12.0p4->3.12.0p6 resolve to dbus-1.
Full dependency tree is libffi-3.2.1p5 .libs-libiconv-1.14p3 gettext-0.19.8.1p
Checking packages|No change in noto-fonts-20171024No change in not
|library atk-bridge-2.0.0.1 not found
| /usr/local/lib/libatk-bridge-2.0.so.0.0 (at-spi2-atk-2.26.2): minor is too s
|library atspi.0.3 not found
| /usr/local/lib/libatspi.so.0.2 (at-spi2-core-2.28.0p0): minor is too small
|library cups.7.1 not found
| /usr/local/lib/libcups.so.6.4 (cups-libs-2.2.8p0): bad major
|library gdk-3.2201.1 not found
| /usr/local/lib/libgdk-3.so.2000.3 (.libs-gtk+3-3.20.6): bad major
| /usr/local/lib/libgdk-3.so.2200.3 (gtk+3-3.22.30p4): bad major
|library gtk-3.2201.0 not found
| /usr/local/lib/libgtk-3.so.2000.3 (.libs-gtk+3-3.20.6): bad major
| /usr/local/lib/libgtk-3.so.2200.3 (gtk+3-3.22.30p4): bad major
|library harfbuzz.15.0 not found
| /usr/local/lib/libharfbuzz.so.8.2 (.libs-harfbuzz-1.2.7): bad major
| /usr/local/lib/libharfbuzz.so.9.5 (.libs-harfbuzz-1.7.6): bad major
| /usr/local/lib/libharfbuzz.so.12.1 (harfbuzz-1.9.0): bad major
Direct dependencies for chromium-69.0.3497.100p0->79.0.3945.117 resolve to har
Full dependency tree is .libs-spidermonkey-52.8.1v1 graphite2-1.3.13p0 gdk-pix
Checking packages|No change in clucene-core-2.3.3.4p3No change in
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of glib2-2.56.3p0 on gettext-* don't match
| Dependencies of libksba-1.3.5p1 on gettext-* don't match
| Dependencies of coreutils-8.30 on gettext-* don't match
| Dependencies of gdbm-1.16 on gettext-* don't match
| Dependencies of inkscape-0.92.3p3 on gettext-* don't match
| Dependencies of vim-8.1.0438-gtk2 on gettext-* don't match
| Dependencies of aspell-0.60.6.1p6 on gettext-* don't match
| Dependencies of poppler-0.59.0 on gettext-* don't match
| Dependencies of a2ps-4.14p14 on gettext-* don't match
| Dependencies of pico-5.09 on gettext-* don't match
| Dependencies of gnupg-2.2.10 on gettext-* don't match
| Dependencies of calibre-2.85.1p7 on gettext-* don't match
| Dependencies of alpine-2.21p0 on gettext-* don't match
| Dependencies of git-2.19.1 on gettext-* don't match
| Dependencies of libgpg-error-1.32 on gettext-* don't match
| Dependencies of gmake-4.2.1 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of gstreamer-0.10.36p12 on gettext-* don't match
| Dependencies of lyx-2.2.3p2 on gettext-* don't match
| Dependencies of tnef-1.4.12p0 on gettext-* don't match
| Dependencies of wxWidgets-gtk2-2.8.12p16 on gettext-* don't match
| Dependencies of popt-1.16p1 on gettext-* don't match
| Dependencies of mailutil-uw-2.21v0 on gettext-* don't match
| Dependencies of python-2.7.15p0 on gettext-* don't match
| Dependencies of libidn-1.35 on gettext-* don't match
| Dependencies of bash-4.4.23 on gettext-* don't match
| Dependencies of gtar-1.30p0 on gettext-* don't match
| Dependencies of clisp-2.49p2 on gettext-* don't match
| Dependencies of gnupg-1.4.23 on gettext-* don't match
| Dependencies of qtbase-5.9.6p1 on gettext-* don't match
| Dependencies of libexif-0.6.21p1 on gettext-* don't match
| Dependencies of dos2unix-7.4.0 on gettext-* don't match
| Dependencies of wget-1.19.5 on gettext-* don't match
| Dependencies of gettext-tools-0.19.8.1 on gettext-* don't match
| Dependencies of gnuplot-5.2.4 on gettext-* don't match
| Dependencies of vlc-2.2.8p2 on gettext-* don't match
| Dependencies of nano-3.1 on gettext-* don't match
| Dependencies of python-3.6.6p1 on gettext-* don't match
| Dependencies of recode-3.6p11 on gettext-* don't match
| Dependencies of p11-kit-0.23.2p1 on gettext-* don't match
| Dependencies of e2fsprogs-1.42.12p4 on gettext-* don't match
| Dependencies of gsed-4.2.2p1 on gettext-* don't match
| Dependencies of rxvt-unicode-9.22p6 on gettext-* don't match
Checking packages|No need to update python-3.5.2NOT MERGING: can't
Merging glib2-2.56.3p0->2.60.7p0 (ok)
Merging libksba-1.3.5p1->1.3.5p2 (ok)
Merging coreutils-8.30->8.31p1 (ok)
Merging gdbm-1.16->1.18.1p0 (ok)
Merging inkscape-0.92.3p3->0.92.4p1 (ok)
Merging vim-8.1.0438-gtk2->8.1.2061-gtk2 (ok)
Merging aspell-0.60.6.1p6->0.60.6.1p10 (ok)
Merging poppler-0.59.0->0.81.0 (ok)
Merging a2ps-4.14p14->4.14p15 (ok)
Merging pico-5.09->5.09p20 (ok)
Merging gnupg-2.2.10->2.2.12p0 (ok)
Merging calibre-2.85.1p7->2.85.1p10 (ok)
Merging alpine-2.21p0->2.21p3 (ok)
Merging git-2.19.1->2.24.2 (ok)
Merging libgpg-error-1.32->1.36p0 (ok)
Merging gmake-4.2.1->4.2.1p4 (ok)
Checking packages|No need to update python-3.4.5NOT MERGING: can't
Merging gstreamer-0.10.36p12->0.10.36p13 (ok)
Merging lyx-2.2.3p2->2.3.2p1 (ok)
Merging tnef-1.4.12p0->1.4.12p1 (ok)
Merging wxWidgets-gtk2-2.8.12p16->wxWidgets-gtk3-3.0.4p2 (ok)
Merging popt-1.16p1->1.16p2 (ok)
Merging mailutil-uw-2.21v0->2.21p3v0 (ok)
Merging python-2.7.15p0->2.7.16p1 (ok)
Merging libidn-1.35->1.35p0 (ok)
Merging bash-4.4.23->5.0.11 (ok)
Merging gtar-1.30p0->1.32p1 (ok)
Merging clisp-2.49p2->2.49p4 (ok)
Merging gnupg-1.4.23->1.4.23p3 (ok)
Merging qtbase-5.9.6p1->5.9.7p6 (ok)
Merging libexif-0.6.21p1->0.6.21p2 (ok)
Merging dos2unix-7.4.0->7.4.0p0 (ok)
Merging wget-1.19.5->1.20.3p1 (ok)
Merging gettext-tools-0.19.8.1->0.20.1p2 (ok)
Merging gnuplot-5.2.4->5.2.5p1 (ok)
Merging vlc-2.2.8p2->2.2.8p7 (ok)
Merging nano-3.1->4.4 (ok)
Merging python-3.6.6p1->3.6.9 (ok)
Merging recode-3.6p11->3.6p12 (ok)
Merging p11-kit-0.23.2p1->0.23.18.1 (ok)
Merging e2fsprogs-1.42.12p4->1.42.12p5 (ok)
Merging gsed-4.2.2p1->4.2.2p3 (ok)
Merging rxvt-unicode-9.22p6->9.22p10 (ok)
.libs-glib2-2.54.3p1+.libs-libidn-1.33p0+.libs1-gdbm-1.13+.libs1-poppler-0.45.
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of python-tkinter-2.7.15p0 on python-2.7.15p0 don't match
| Dependencies of audacity-1.3.9p12 on wxWidgets-gtk2->=2.8.6 don't match
| Dependencies of py-wxPython-2.8.12.0p4 on wxWidgets-gtk2->=2.8.12 don't matc
| Dependencies of python-3.4.5 on gettext-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Merging python-tkinter-2.7.15p0->2.7.16 (ok)
Merging audacity-1.3.9p12->2.3.2 (ok)
Merging py-wxPython-2.8.12.0p4->3.0.2.0p0 (ok)
Checking packages|No need to update python-3.4.5NOT MERGING: can't
Checking packages|No need to update python-3.5.2NOT MERGING: can't
.libs-glib2-2.54.3p1+.libs-libidn-1.33p0+.libs1-gdbm-1.13+.libs1-poppler-0.45.
| Dependencies of wxMaxima-12.09.0p1 on wxWidgets-gtk2-* don't match
| Dependencies of python-3.5.2 on gettext-* don't match
| Dependencies of python-3.4.5 on gettext-* don't match
NOT MERGING: can't find update for wxMaxima-12.09.0p1-> (ok)
Checking packages|No need to update python-3.5.2NOT MERGING: can't
Checking packages|No need to update python-3.4.5NOT MERGING: can't
Can't install .libs-glib2-2.54.3p1+.libs-libidn-1.33p0+.libs1-gdbm-1.13+.libs1
Checking packages|No change in libotf-0.9.16Can't install m17n-lib-
Can't install emacs-26.1p2-gtk3->26.3-gtk3: can't resolve m17n-lib-1.8.0p2
Checking packages|No change in enca-1.19p0No change in espeak-1.48
Direct dependencies for json-glib-1.4.4->1.4.4 resolve to glib2-2.56.3p0
Full dependency tree is bzip2-1.0.8 sqlite3-3.29.0 libiconv-1.16p0 pcre-8.41p2
Can't install geoclue2-2.4.13 because of libraries
|library soup-2.4.10.3 not found
| /usr/local/lib/libsoup-2.4.so.9.2 (.libs1-libsoup-2.58.2p0): bad major
| /usr/local/lib/libsoup-2.4.so.10.1 (libsoup-2.62.3): minor is too small
Direct dependencies for geoclue2-2.4.12->2.4.13 resolve to libnotify-0.7.7 jso
Full dependency tree is python-3.6.6p1 bzip2-1.0.8 sqlite3-3.29.0 libffi-3.2.1
Can't install webkitgtk4-2.26.4p1 because of libraries
|library enchant-2.0.1 not found
| /usr/local/lib/libenchant-2.so.0.0 (enchant2-2.2.3): minor is too small
|library gstapp-1.0.5.0 not found
| /usr/local/lib/libgstapp-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.4):
| /usr/local/lib/libgstapp-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): bad ma
|library gstaudio-1.0.5.0 not found
| /usr/local/lib/libgstaudio-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.4)
| /usr/local/lib/libgstaudio-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): bad
|library gstbase-1.0.5.0 not found
| /usr/local/lib/libgstbase-1.0.so.4.0 (gstreamer1-1.14.4): bad major
|library gstfft-1.0.5.0 not found
| /usr/local/lib/libgstfft-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.4):
| /usr/local/lib/libgstfft-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): bad ma
|library gstgl-1.0.4.0 not found
| /usr/local/lib/libgstgl-1.0.so.3.0 (gstreamer1-plugins-base-1.14.4): bad maj
|library gstpbutils-1.0.5.0 not found
| /usr/local/lib/libgstpbutils-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.
| /usr/local/lib/libgstpbutils-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): ba
|library gstreamer-1.0.5.0 not found
| /usr/local/lib/libgstreamer-1.0.so.4.0 (gstreamer1-1.14.4): bad major
|library gsttag-1.0.5.0 not found
| /usr/local/lib/libgsttag-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.4):
| /usr/local/lib/libgsttag-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): bad ma
|library gstvideo-1.0.5.0 not found
| /usr/local/lib/libgstvideo-1.0.so.3.3 (.libs-gstreamer1-plugins-base-1.12.4)
| /usr/local/lib/libgstvideo-1.0.so.4.0 (gstreamer1-plugins-base-1.14.4): bad
|library harfbuzz-icu.1.2 not found
| /usr/local/lib/libharfbuzz-icu.so.0.6 (.libs-harfbuzz-icu-1.7.6): bad major
| /usr/local/lib/libharfbuzz-icu.so.1.0 (harfbuzz-icu-1.9.0): minor is too sma
|library secret-1.2.0 not found
| /usr/local/lib/libsecret-1.so.1.0 (libsecret-0.18.6): bad major
Direct dependencies for webkitgtk4-2.22.2->2.26.4p1 resolve to geoclue2-2.4.12
Full dependency tree is orc-0.4.29 dbus-daemon-launch-helper-1.12.16 libnettle
Can't install librest-0.8.1p0 because of libraries
|library psl.1.2 not found
| not found anywhere
|library soup-gnome-2.4.8.1 not found
| /usr/local/lib/libsoup-gnome-2.4.so.8.0 (libsoup-2.62.3): minor is too small
Direct dependencies for librest-0.8.1->0.8.1p0 resolve to libsoup-2.62.3
Full dependency tree is xz-5.2.4 libxml-2.9.8p0 libnettle-3.5.1 gettext-0.19.8
Can't install gnome-online-accounts-3.32.0 because of libraries
|library javascriptcoregtk-4.0.3.1 not found
| /usr/local/lib/libjavascriptcoregtk-4.0.so.2.5 (webkitgtk4-2.22.2): bad majo
|library openjp2.3.1 not found
| /usr/local/lib/libopenjp2.so.1.0 (.libs1-openjp2-2.1.0): bad major
| /usr/local/lib/libopenjp2.so.3.1 (openjp2-2.3.1): not reachable
|library webkit2gtk-4.0.3.1 not found
| /usr/local/lib/libwebkit2gtk-4.0.so.2.5 (webkitgtk4-2.22.2): bad major
Direct dependencies for gnome-online-accounts-3.28.0p2->3.32.0 resolve to webk
Full dependency tree is hicolor-icon-theme-0.17 xz-5.2.4 libxslt-1.1.32 gstrea
Checking packages|No change in liboauth-1.0.3Can't install libgdata
Direct dependencies for libgdata-0.17.9p1->0.17.11 resolve to gcr-3.28.0p3 lib
Full dependency tree is pinentry-1.1.0p0 libiconv-1.16p0 gstreamer1-plugins-ba
Checking packages|No change in openldap-client-2.4.48No change in
Direct dependencies for libcanberra-gtk3-0.30p8 resolve to gtk+3-3.22.30p4 lib
Full dependency tree is xz-5.2.4 shared-mime-info-1.10p4 hicolor-icon-theme-0.
Can't install geocode-glib-3.26.1 because of libraries
Direct dependencies for geocode-glib-3.26.0p0->3.26.1 resolve to libsoup-2.62.
Full dependency tree is libsoup-2.62.3 libtasn1-4.14 glib2-2.56.3p0 glib2-netw
Can't install libgweather-3.32.2p0 because of libraries
Direct dependencies for libgweather-3.28.2p1->3.32.2p0 resolve to geocode-glib
Full dependency tree is png-1.6.37 libiconv-1.16p0 gdk-pixbuf-2.36.12 at-spi2-
Checking packages|No change in libical-3.0.6Can't install evolution
Checking packages|No change in p5-URI-1.76No change in yelp-xsl-3.
Direct dependencies for yelp-3.28.1p2->3.32.2 resolve to xz-5.2.4 dconf-0.28.0
Full dependency tree is icu4c-64.2p0 .libs-icu4c-58.2p6 brotli-1.0.7 .libs-lib
Checking packages|No change in gnome-devel-docs-3.32.1Can't install
Direct dependencies for amtk-5.0.1p0 resolve to gtk+3-3.22.30p4
Full dependency tree is libelf-0.8.13p4 gtk+3-3.22.30p4 adwaita-icon-theme-3.2
Can't install devhelp-3.32.0: can't resolve amtk-5.0.1p0
Can't install py3-MarkupSafe-1.1.1: can't resolve python-3.7.4
Can't install py3-cryptodome-3.8.2: can't resolve python-3.7.4
Can't install py3-beaker-1.10.0p0: can't resolve python-3.7.4,py3-cryptodome-3
Can't install py3-mako-1.1.0: can't resolve py3-MarkupSafe-1.1.1,py3-beaker-1.
Can't install gobject-introspection-1.60.2: can't resolve python-3.7.4,py3-mak
Checking packages|No change in py-gobject3-common-3.32.2Can't insta
Can't install glade-3.22.1p2: can't resolve devhelp-3.32.0,py-gobject3-3.32.2
Can't install libxfce4util-4.14.0 because of libraries
Direct dependencies for libxfce4util-4.12.1p0->4.14.0 resolve to glib2-2.56.3p
Full dependency tree is python-2.7.15p0 libelf-0.8.13p4 glib2-2.56.3p0 gettext
Can't install xfconf-4.14.1 because of libraries
|library xfce4util.4.1 not found
| /usr/local/lib/libxfce4util.so.4.0 (libxfce4util-4.12.1p0): minor is too sma
Direct dependencies for xfconf-4.12.1p0->4.14.1 resolve to libxfce4util-4.12.1
Full dependency tree is bzip2-1.0.8 sqlite3-3.29.0 pcre-8.41p2 glib2-2.56.3p0
Can't install libxfce4util-4.14.0 because of libraries
Direct dependencies for libxfce4util-4.12.1p0->4.14.0 resolve to glib2-2.56.3p
Full dependency tree is .libs-libiconv-1.14p3 libffi-3.2.1p5 gettext-0.19.8.1p
Can't install libxfce4ui-4.12.1p8->4.14.1: can't resolve glade-3.22.1p2,libxfc
Can't install exo-0.12.8 because of libraries
|library xfce4ui-2.0.1 not found
| /usr/local/lib/libxfce4ui-2.so.0.0 (libxfce4ui-4.12.1p8): minor is too small
Direct dependencies for exo-0.12.2p1->0.12.8 resolve to libxfce4util-4.12.1p0
Full dependency tree is atk-2.28.1 gtk+2-2.24.32p2 desktop-file-utils-0.23p9 x
Can't install ffmpegthumbnailer-2.2.0 because of libraries
|library avfilter.8.0 not found
| /usr/local/lib/libavfilter.so.7.3 (ffmpeg-2.8.15v0): bad major
Direct dependencies for ffmpegthumbnailer-2.2.0->2.2.0 resolve to ffmpeg-2.8.1
Full dependency tree is libass-0.14.0p0 fribidi-1.0.7p0 xvidcore-1.3.5p0 .libs
Can't install firefox-esr-68.8.0 because of libraries
Direct dependencies for .libs-firefox-esr-45.2.0+.libs-firefox-esr-52.7.3+.lib
Full dependency tree is pango-1.42.4p0 glib2-2.56.3p0 pcre-8.41p2 cairo-1.15.1
Checking packages|No change in flite-1.2p6No change in freeglut-3.
|library xfce4ui-1.0.2 not found
| /usr/local/lib/libxfce4ui-1.so.0.1 (libxfce4ui-4.12.1p8): minor is too small
Direct dependencies for garcon-0.6.1p2->0.6.4 resolve to libxfce4util-4.12.1p0
Full dependency tree is dconf-0.28.0p1 at-spi2-core-2.28.0p0 tiff-4.0.10 pytho
Checking packages|No change in gcc-8.3.0p4No change in mpfr-3.1.5.
Direct dependencies for gconf2-3.2.6p11->3.2.6p11 resolve to dbus-glib-0.110v0
Full dependency tree is gettext-0.19.8.1p1 libffi-3.2.1p5 .libs-libiconv-1.14p
Can't install gegl-0.2.2p2 because of libraries
|library rsvg-2.39.1 not found
| /usr/local/lib/librsvg-2.so.38.2 (.libs-librsvg-2.40.20): bad major
| /usr/local/lib/librsvg-2.so.39.0 (librsvg-2.44.6p0): minor is too small
Direct dependencies for gegl-0.2.2p0->0.2.2p2 resolve to librsvg-2.44.6p0 babl
Full dependency tree is libelf-0.8.13p4 lzo2-2.10p1 sqlite3-3.29.0 harfbuzz-1.
Can't install gimp-2.8.22p5 because of libraries
|library cupsimage.6.1 not found
| /usr/local/lib/libcupsimage.so.5.1 (cups-libs-2.2.8p0): bad major
|library gnutls.46.3 not found
| /usr/local/lib/libgnutls.so.44.1 (gnutls-3.5.19): bad major
|library p11-kit.3.0 not found
| /usr/local/lib/libp11-kit.so.2.0 (p11-kit-0.23.2p1): bad major
|library poppler-glib.19.3 not found
| /usr/local/lib/libpoppler-glib.so.15.0 (.libs1-poppler-0.45.0p0): bad major
| /usr/local/lib/libpoppler-glib.so.17.0 (poppler-0.59.0): bad major
|library poppler.56.0 not found
| /usr/local/lib/libpoppler.so.39.0 (.libs1-poppler-0.45.0p0): bad major
| /usr/local/lib/libpoppler.so.44.0 (.libs1-poppler-0.57.0): bad major
| /usr/local/lib/libpoppler.so.45.0 (poppler-0.59.0): bad major
Direct dependencies for gimp-2.8.22p3->2.8.22p5 resolve to desktop-file-utils-
Full dependency tree is gnutls-3.5.19 poppler-0.59.0 dbus-1.12.16v0 cairo-1.15
Checking packages|No change in glm-0.9.8.5No change in gnustep-lib
|library gnutls.46.3 not found
| /usr/local/lib/libgnutls.so.43.1 (.libs-gnutls-3.4.14): bad major
| /usr/local/lib/libgnutls.so.44.1 (gnutls-3.5.19): bad major
Direct dependencies for gnustep-base-1.25.1p0->1.26.0p0 resolve to libffi-3.2.
Full dependency tree is gdbm-1.16 glib2-2.56.3p0 libtasn1-4.14 python-2.7.15p0
Checking packages|No change in libao-1.2.0p1Can't install gnustep-g
|library gnustep-base.10.2 not found
| /usr/local/lib/libgnustep-base.so.10.1 (gnustep-base-1.25.1p0): minor is too
Direct dependencies for gnustep-gui-0.26.2->0.27.0p0 resolve to jpeg-2.0.3v0 l
Full dependency tree is gnustep-make-2.7.0p2 libsndfile-1.0.28 png-1.6.37 libi
Can't install gnustep-back-0.27.0 because of libraries
|library gnustep-gui.0.29 not found
| /usr/local/lib/libgnustep-gui.so.0.28 (gnustep-gui-0.26.2): minor is too sma
Direct dependencies for gnustep-back-0.26.2->0.27.0 resolve to gnustep-gui-0.2
Full dependency tree is lzo2-2.10p1 libao-1.2.0p1 .libs-giflib-5.1.4 gnustep-b
Checking packages|No change in gocr-0.48p0No change in gphoto-2.5.
Direct dependencies for gspdf-0.5p8->0.5p9 resolve to gnustep-back-0.26.2 ghos
Full dependency tree is libogg-1.3.4 gdbm-1.16 glib2-2.56.3p0 libtasn1-4.14 gh
Checking packages|No change in wavpack-5.1.0p2No change in libshou
Direct dependencies for gstreamer-plugins-good-0.10.31p23v0->0.10.31p25v0 reso
Full dependency tree is png-1.6.37 speexdsp-1.2.0 at-spi2-atk-2.26.2 gdk-pixbu
Can't install gtk-xfce-engine-3.2.0p4 because of libraries
Direct dependencies for gtk-xfce-engine-3.2.0p2->3.2.0p4 resolve to gtk+2-2.24
Full dependency tree is lzo2-2.10p1 libelf-0.8.13p4 gnome-icon-theme-3.12.0p5
Can't install gtksourceview3-3.24.11 because of libraries
Direct dependencies for gtksourceview3-3.24.9->3.24.11 resolve to libxml-2.9.8
Full dependency tree is atk-2.28.1 png-1.6.37 libiconv-1.16p0 gdk-pixbuf-2.36.
Checking packages|No change in gv-3.7.4p0No change in help2man-1.4
Can't install py3-ipython_genutils-0.2.0->0.2.0p1: can't resolve python-3.7.4
Can't install py3-six-1.11.0->1.12.0p1: can't resolve python-3.7.4
Can't install py3-traitlets-4.3.2->4.3.2p1: can't resolve python-3.7.4
Can't install py3-ptyprocess-0.5.1p0->0.5.1p1: can't resolve python-3.7.4
Can't install py3-pexpect-4.2.1p0->4.7.0p1: can't resolve python-3.7.4
Can't install py3-pickleshare-0.7.4p1->0.7.4p3: can't resolve python-3.7.4
Can't install py3-wcwidth-0.1.7p0->0.1.7p1: can't resolve python-3.7.4
Can't install py3-pygments-2.1.3p0->2.4.2: can't resolve python-3.7.4
Can't install py3-prompt_toolkit-1.0.15->1.0.15p0: can't resolve python-3.7.4
Can't install py3-simplegeneric-0.8.1p3->0.8.1p4: can't resolve python-3.7.4
Can't install ipython3-5.3.0p0->5.8.0p0: can't resolve python-3.7.4
Checking packages|No change in jed-0.99.19p2No change in libslang-
libelf-0.8.13p4-> forward dependencies:
| Dependencies of glib2-2.56.3p0 on libelf-* don't match
Merging glib2-2.56.3p0->2.60.7p0 (ok)
Can't install .libs-glib2-2.54.3p1+glib2-2.56.3p0+libelf-0.8.13p4->glib2-2.60.
Can't install libgsf-1.14.46 because of libraries
Direct dependencies for libgsf-1.14.44->1.14.46 resolve to gdk-pixbuf-2.36.12
Full dependency tree is gettext-0.19.8.1p1 jasper-2.0.14 jpeg-2.0.3v0 libffi-3
Checking packages|No change in libmp3splt-0.5.4p4Can't install libm
Direct dependencies for libmtp-1.1.15->1.1.15 resolve to libusb1-1.0.21p1 libg
Full dependency tree is libusb1-1.0.21p1 libgcrypt-1.8.3 libiconv-1.16p0 libgp
Checking packages|No change in libqrencode-4.0.2No change in maria
Direct dependencies for rasqal-0.9.33p2->0.9.33p2 resolve to libgcrypt-1.8.3 r
Full dependency tree is gettext-0.19.8.1p1 e2fsprogs-1.42.12p4 curl-7.66.0 gmp
Can't install redland-1.0.17p6 because of libraries
Direct dependencies for redland-1.0.17p5->1.0.17p6 resolve to libltdl-2.4.2p1
Full dependency tree is gettext-0.19.8.1p1 e2fsprogs-1.42.12p4 curl-7.66.0 .li
Checking packages|No change in postgresql-client-11.7Can't install
Can't install libunique-1.1.6p13 because of libraries
Direct dependencies for libunique-1.1.6p12->1.1.6p13 resolve to gtk+2-2.24.32p
Full dependency tree is fribidi-1.0.7p0 libxml-2.9.8p0 .libs-jpeg-2.0.0v0 gtk-
Can't install libwnck-2.30.7p10 because of libraries
Direct dependencies for libwnck-2.30.7p9->2.30.7p10 resolve to startup-notific
Full dependency tree is libffi-3.2.1p5 librsvg-2.44.6p0 graphite2-1.3.13p0 lib
Can't install libxklavier-5.4 because of libraries
Direct dependencies for libxklavier-5.4->5.4 resolve to glib2-2.56.3p0 iso-cod
Full dependency tree is sqlite3-3.29.0 pcre-8.41p2 bzip2-1.0.8 iso-codes-4.2p0
Checking packages|No change in libyaml-0.2.2No change in lua-5.3.5
|library xfconf-0.1.0 not found
| /usr/local/lib/libxfconf-0.so.0.1 (xfconf-4.12.1p0): bad major
Direct dependencies for mousepad-0.4.1p1->0.4.2 resolve to gtksourceview3-3.24
Full dependency tree is lzo2-2.10p1 libelf-0.8.13p4 gtk+3-3.22.30p4 adwaita-ic
Checking packages|No change in mp3splt-2.2.3p0No change in mpg123-
|library postproc.17.0 not found
| /usr/local/lib/libpostproc.so.16.1 (ffmpeg-2.8.15v0): bad major
|library swresample.2.0 not found
| /usr/local/lib/libswresample.so.1.2 (ffmpeg-2.8.15v0): bad major
Direct dependencies for mplayer-20180916p0->20190817p0 resolve to bzip2-1.0.8
Full dependency tree is ffmpeg-2.8.15v0 gsm-1.0.18 tiff-4.0.10 flac-1.3.3 .lib
Checking packages|No change in ogle-0.9.2p23No change in opusfile-
Direct dependencies for xfconf-4.12.1p0->4.14.1 resolve to libxfce4util-4.12.1
Full dependency tree is glib2-2.56.3p0 python-2.7.15p0 libelf-0.8.13p4 bzip2-1
Can't install libxfce4ui-4.12.1p8->4.14.1: can't resolve glade-3.22.1p2,libxfc
Can't install libwnck3-3.32.0 because of libraries
Direct dependencies for libwnck3-3.32.0 resolve to gtk+3-3.22.30p4 startup-not
Full dependency tree is lzo2-2.10p1 adwaita-icon-theme-3.28.0p1 libelf-0.8.13p
Can't install xfce4-panel-4.12.2p2->4.14.1: can't resolve libxfce4ui-4.14.1,li
Can't install orage-4.12.1p9 because of libraries
|library xfce4panel-1.0.1.1 not found
| /usr/local/lib/libxfce4panel-1.0.so.1.0 (xfce4-panel-4.12.2p2): minor is too
Direct dependencies for orage-4.12.1p6->4.12.1p9 resolve to gtk-update-icon-ca
Full dependency tree is dbus-1.12.16v0 cairo-1.15.12 pcre-8.41p2 startup-notif
Checking packages|No change in p9m4-05p2No change in py-modulegrap
Direct dependencies for py-matplotlib-1.5.3p8->2.2.4p0 resolve to py-gtk2-2.24
Full dependency tree is gtk+2-2.24.32p2 py-functools32-3.2.3 blas-3.7.1 atk-2.
Checking packages|No change in py-mpmath-1.1.0No change in py-nltk
|library QtDBus.3.0 not found
| /usr/local/lib/libQtDBus.so.2.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtDBus.so.2.0 (qt4-4.8.7p17): bad major
|library QtDeclarative.1.0 not found
| /usr/local/lib/libQtDeclarative.so.0.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtDeclarative.so.0.0 (qt4-4.8.7p17): bad major
|library QtDesigner.8.0 not found
| /usr/local/lib/libQtDesigner.so.7.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtDesigner.so.7.0 (qt4-4.8.7p17): bad major
|library QtGui.11.0 not found
| /usr/local/lib/libQtGui.so.10.1 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtGui.so.10.1 (qt4-4.8.7p17): bad major
|library QtHelp.2.0 not found
| /usr/local/lib/libQtHelp.so.1.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtHelp.so.1.0 (qt4-4.8.7p17): bad major
|library QtMultimedia.1.0 not found
| /usr/local/lib/libQtMultimedia.so.0.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtMultimedia.so.0.0 (qt4-4.8.7p17): bad major
|library QtNetwork.11.0 not found
| /usr/local/lib/libQtNetwork.so.10.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtNetwork.so.10.0 (qt4-4.8.7p17): bad major
|library QtOpenGL.8.0 not found
| /usr/local/lib/libQtOpenGL.so.7.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtOpenGL.so.7.0 (qt4-4.8.7p17): bad major
|library QtScript.3.0 not found
| /usr/local/lib/libQtScript.so.2.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtScript.so.2.0 (qt4-4.8.7p17): bad major
|library QtScriptTools.1.0 not found
| /usr/local/lib/libQtScriptTools.so.0.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtScriptTools.so.0.0 (qt4-4.8.7p17): bad major
|library QtSql.9.0 not found
| /usr/local/lib/libQtSql.so.8.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtSql.so.8.0 (qt4-4.8.7p17): bad major
|library QtSvg.8.0 not found
| /usr/local/lib/libQtSvg.so.7.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtSvg.so.7.0 (qt4-4.8.7p17): bad major
|library QtTest.8.0 not found
| /usr/local/lib/libQtTest.so.7.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtTest.so.7.0 (qt4-4.8.7p17): bad major
|library QtWebKit.5.0 not found
| /usr/local/lib/libQtWebKit.so.4.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtWebKit.so.4.0 (qt4-4.8.7p17): bad major
|library QtXml.9.0 not found
| /usr/local/lib/libQtXml.so.8.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtXml.so.8.0 (qt4-4.8.7p17): bad major
|library QtXmlPatterns.1.0 not found
| /usr/local/lib/libQtXmlPatterns.so.0.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtXmlPatterns.so.0.0 (qt4-4.8.7p17): bad major
|library lib/qt4/QtCore.10.0 not found
| /usr/local/lib/libQtCore.so.9.0 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libQtCore.so.9.0 (qt4-4.8.7p17): bad major
|library phonon.5.0 not found
| /usr/local/lib/libphonon.so.4.1 (qt4-4.8.7p17): bad major
| /usr/local/lib/qt4/libphonon.so.4.1 (qt4-4.8.7p17): bad major
Direct dependencies for py-qt4-4.12p1v0->4.12p2v0 resolve to python-2.7.15p0 p
Full dependency tree is gstreamer-0.10.36p12 npth-1.6 libdaemon-0.14p1 libgpg-
Checking packages|No change in py-sympy-1.4No change in py-unideco
Can't install py3-sympy-1.1p0->1.4: can't resolve python-3.7.4
Checking packages|No change in qtscript-5.9.7p1Can't install ristre
Direct dependencies for ristretto-0.8.3->0.10.0 resolve to libxfce4ui-4.12.1p8
Full dependency tree is pango-1.42.4p0 glib2-2.56.3p0 cairo-1.15.12 pcre-8.41p
Checking packages|No change in rsync-3.1.3No change in sane-backen
Can't install thunar-1.6.15p2->1.8.9: can't resolve libxfce4ui-4.14.1
Can't install tumbler-0.2.7 because of libraries
|library avresample.2.0 not found
| /usr/local/lib/libavresample.so.1.0 (ffmpeg-2.8.15v0): bad major
|library dav1d.2.0 not found
| not found anywhere
|library theoradec.2.0 not found
| /usr/local/lib/libtheoradec.so.1.1 (.libs-libtheora-1.1.1p3): bad major
| /usr/local/lib/libtheoradec.so.2.0 (libtheora-1.2.20190601p0): not reachable
|library theoraenc.2.0 not found
| /usr/local/lib/libtheoraenc.so.1.2 (.libs-libtheora-1.1.1p3): bad major
| /usr/local/lib/libtheoraenc.so.2.0 (libtheora-1.2.20190601p0): not reachable
Direct dependencies for tumbler-0.2.3->0.2.7 resolve to curl-7.66.0 jpeg-2.0.3
Full dependency tree is ffmpegthumbnailer-2.2.0 .libs-x265-2.8 libelf-0.8.13p4
Checking packages|No change in unzip-6.0p13Can't install upower-0.9
Direct dependencies for upower-0.99.7p0->0.99.9p0 resolve to dbus-daemon-launc
Full dependency tree is .libs-libiconv-1.14p3 libffi-3.2.1p5 dbus-daemon-launc
Checking packages|No change in usbutils-007p0No change in vamp-plu
Direct dependencies for vte3-0.52.2->0.56.3 resolve to gtk+3-3.22.30p4 pcre2-1
Full dependency tree is png-1.6.37 at-spi2-atk-2.26.2 gdk-pixbuf-2.36.12 libic
Can't install xfce4-screensaver-0.1.8: can't resolve libwnck3-3.32.0
Can't install xfwm4-4.12.5->4.14.0: can't resolve libwnck3-3.32.0
Checking packages|No change in xfwm4-themes-4.10.0p0Can't install x
Direct dependencies for xfconf-4.12.1p0->4.14.1 resolve to libxfce4util-4.12.1
Full dependency tree is glib2-2.56.3p0 libelf-0.8.13p4 python-2.7.15p0 sqlite3
Can't install xfce4-appfinder-4.12.0p3->4.14.0: can't resolve xfconf-4.14.1
Can't install xfce4-mixer-4.11.0p8 because of libraries
Direct dependencies for xfce4-mixer-4.11.0p5->4.11.0p8 resolve to gstreamer-0.
Full dependency tree is libexecinfo-0.3p2v0 libusb1-1.0.21p1 python-3.6.6p1 lz
Can't install gtk2-murrine-engine-0.98.2p9: can't resolve gettext-runtime-0.20
Can't install greybird-3.22.10: can't resolve gtk2-murrine-engine-0.98.2p9
Can't install xfce4-notifyd-0.4.4p0 because of libraries
|library xfce4panel-2.0.0.1 not found
| /usr/local/lib/libxfce4panel-2.0.so.0.0 (xfce4-panel-4.12.2p2): minor is too
Direct dependencies for xfce4-notifyd-0.4.2p1->0.4.4p0 resolve to gtk-update-i
Full dependency tree is gtk+3-3.22.30p4 p5-URI-1.76 lzo2-2.10p1 sqlite3-3.29.0
Can't install xfce4-session-4.12.1p6->4.14.0: can't resolve libwnck3-3.32.0
Can't install xfce4-settings-4.14.1 because of libraries
Direct dependencies for xfce4-settings-4.12.4p0->4.14.1 resolve to exo-0.12.2p
Full dependency tree is gtk-update-icon-cache-3.22.30p1 shared-mime-info-1.10p
Can't install xfce4-taskmanager-1.2.0p2->1.2.2p3: can't resolve libwnck3-3.32.
Can't install xfce4-terminal-0.8.8p0 because of libraries
|library vte-2.91.2.4 not found
| /usr/local/lib/libvte-2.91.so.2.2 (vte3-0.52.2): minor is too small
Direct dependencies for xfce4-terminal-0.8.7.4p0->0.8.8p0 resolve to vte3-0.52
Full dependency tree is lzo2-2.10p1 gtk+3-3.22.30p4 harfbuzz-1.9.0 bzip2-1.0.8
Can't install thunar-1.6.15p2->1.8.9: can't resolve libxfce4ui-4.14.1
Can't install xfdesktop-4.12.4p2->4.14.1: can't resolve thunar-1.8.9,libwnck3-
Can't install xfce-4.12p10->4.14: can't resolve greybird-3.22.10,xfce4-screens
Checking packages|No change in xfig-3.2.6p1No change in xpdf-3.04p
Direct dependencies for xsane-0.999p4->0.999p4 resolve to lcms-1.19 gtk+2-2.24
Full dependency tree is gtk+2-2.24.32p2 libiconv-1.16p0 lcms-1.19 gdk-pixbuf-2
Checking packages|No change in xv-3.10ap15No change in zint-2.6.3p
Obsolete package: libf2c-3.3.6p13 (outdated and/or no longer required by other
Obsolete package: mozjs17-17.0p4 (no longer maintained and full of security ho
Obsolete package: tremor-20180316 (outdated and/or no longer required by other
Couldn't find updates for .libs-ImageMagick-6.9.4.10 .libs-cairo-1.14.12 .libs
Couldn't install ImageMagick-6.9.10.62 a2ps-4.14p15 adwaita-icon-theme-3.32.0
farm# exiy y t

Script done on Thu Jul 30 23:52:35 2020

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Stuart Henderson
On 2020/08/01 16:53, Austin Hook wrote:
>   Stuart suggested sending the entire pkg_add -u" output for a quick scan
> of my foolishness, so I an including it at the bottom of this email --
> lines chopped at character 78, because all the linking stuff makes it half
> a megabyte, which seems excessive to burden the archives with.   Maybe
> seeing the full link into is not necessary to allow one more comment if
> any of you folks care to peek at my pkg_add -u output.

Full output would be better, I think that chopping at column 78 has
truncated some useful information. At least I didn't spot the direct
cause of the problem (though clearly there's an issue with handling
the gettext packages, which was split/renamed - this certainly causes
some issues for pkg_add, though in cases that I've seen before just
rerunning pkg_add -u was enough to clear it up).

Good that you considered the lists (I wish people who send multi-
megabyte fuzzy photos of panic messages that they could have typed in
fairly easily would do the same...) but they can cope with 500K once
in a while, or sending as a gzipped attachment would shrink it a lot.


If you need to get it fixed, the following should do the trick;
save a list of packages, remove them all, and reinstall:

        pkg_info -mz >/root/pkg_list_manual
        pkg_info -z >/root/pkg_list_full
        pkg_delete -X /var/db/pkg/*-firmware-[0-9]*
        pkg_add -z -l /root/pkg_list_manual
        pkg_add -za -l /root/pkg_list_full

but it would be good to get more details if possible first in case
they point at a bug/something missing in pkg_add.

> Merging nano-3.1->4.4 (ok)
> Checking packages|No need to update python-3.4.5 NOT MERGING: can't

The missing text in lines like the above, or in some of the merge lines,
might have something useful. But it's easier to include everything
rather than try to figure out what might help.

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2

Hi Stuart,
   Here's the full typescript attached.  The list itself chops off
attachments I think, but I am sure any of us can delete my email, or even
save after deleting the attachment, as I often do within alpine with long
videos of funny cats, or political polemics that my relatives can't resist
sending.  
   
Austin
 

On Sun, 2 Aug 2020, Stuart Henderson wrote:

> On 2020/08/01 16:53, Austin Hook wrote:
> >   Stuart suggested sending the entire pkg_add -u" output for a quick scan
> > of my foolishness, so I an including it at the bottom of this email --
> > lines chopped at character 78, because all the linking stuff makes it half
> > a megabyte, which seems excessive to burden the archives with.   Maybe
> > seeing the full link into is not necessary to allow one more comment if
> > any of you folks care to peek at my pkg_add -u output.
>
> Full output would be better, I think that chopping at column 78 has
> truncated some useful information. At least I didn't spot the direct
> cause of the problem (though clearly there's an issue with handling
> the gettext packages, which was split/renamed - this certainly causes
> some issues for pkg_add, though in cases that I've seen before just
> rerunning pkg_add -u was enough to clear it up).
>
> Good that you considered the lists (I wish people who send multi-
> megabyte fuzzy photos of panic messages that they could have typed in
> fairly easily would do the same...) but they can cope with 500K once
> in a while, or sending as a gzipped attachment would shrink it a lot.
>
>
> If you need to get it fixed, the following should do the trick;
> save a list of packages, remove them all, and reinstall:
>
> pkg_info -mz >/root/pkg_list_manual
> pkg_info -z >/root/pkg_list_full
> pkg_delete -X /var/db/pkg/*-firmware-[0-9]*
> pkg_add -z -l /root/pkg_list_manual
> pkg_add -za -l /root/pkg_list_full
>
> but it would be good to get more details if possible first in case
> they point at a bug/something missing in pkg_add.
>
> > Merging nano-3.1->4.4 (ok)
> > Checking packages|No need to update python-3.4.5NOT MERGING: can't
>
> The missing text in lines like the above, or in some of the merge lines,
> might have something useful. But it's easier to include everything
> rather than try to figure out what might help.
>
>

typescript (659K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Stuart Henderson
On 2020/08/01 17:38, Austin Hook wrote:
>
> Hi Stuart,
>    Here's the full typescript attached.  The list itself chops off
> attachments I think, but I am sure any of us can delete my email, or even
> save after deleting the attachment, as I often do within alpine with long
> videos of funny cats, or political polemics that my relatives can't resist
> sending.  

Ports@ allows attachments, they are used often.

One problem is that the update path from old Python 3.x to newer 3.x was
broken (I fixed it between 6.6 and 6.7), this gets in the way of merging
gettext from the old to new names - no registered update path so it tries
to keep the old Python package, but the old package depends on old gettext
which conflicts with the newer one.

Either jumping to 6.7 or removing/reinstalling all packages (as per my
previous mail) would fix that problem.

There maybe other problems but it's hard to identify them after the
noise from the first one.

Reply | Threaded
Open this post in threaded view
|

Re: 6.6 pkg_add of firefox vs atk versions

Austin Hook-2
Hi Stuart,

Never knew any of the mailing lists took attachments.   I hope no one
starts posting videos.  

Fascinating about the packages.  Maybe it wasn't all my fault.  That would
be a first time!  And thanks for the reminder of how to save the names of
all the ports.

Yes, I noticed that I was having problems with Python as well.  Was
writing a bit of code to generate DTMF tones for ham radio repeater
controls, plus so I can get dumb phones to listen to long sequences from a
tiny pocket computer, where I can append calling card number and pin to
call US & international long distance for a penny a minute.  

Telus has a new $10 a month "wireless home phone", no charge for the
device, and free calls across Canada, but they are hoping to make up for
it by getting you to sign up for US and international service extra cost.  
Also, they think they have modems, and hence data, blocked in that
service.  I think I can program around that, even if a bit slow.

It's a neat device.  You can take it camping with you, and not have to
forward your base home or office number.  Maybe I can make a poor man's
cell phone out of it, just for fun.

I'll let you know how I make out with the packages.

Austin



On Sun, 2 Aug 2020, Stuart Henderson wrote:

> On 2020/08/01 17:38, Austin Hook wrote:
> >
> > Hi Stuart,
> >    Here's the full typescript attached.  The list itself chops off
> > attachments I think, but I am sure any of us can delete my email, or even
> > save after deleting the attachment, as I often do within alpine with long
> > videos of funny cats, or political polemics that my relatives can't resist
> > sending.  
>
> Ports@ allows attachments, they are used often.
>
> One problem is that the update path from old Python 3.x to newer 3.x was
> broken (I fixed it between 6.6 and 6.7), this gets in the way of merging
> gettext from the old to new names - no registered update path so it tries
> to keep the old Python package, but the old package depends on old gettext
> which conflicts with the newer one.
>
> Either jumping to 6.7 or removing/reinstalling all packages (as per my
> previous mail) would fix that problem.
>
> There maybe other problems but it's hard to identify them after the
> noise from the first one.
>