6.6-current #590 error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

6.6-current #590 error

rgcinjp
misc@

just a heads-up #590 has some issues.

$ uname -a
OpenBSD pcfj10.my.domain 6.6 GENERIC.MP#590 amd64

$ pkg_info -mz
Cwd.c: loadable library and perl binaries are mismatched (got handshake key 0xb700000, needed 0xb600000)

yorosiku ~

Reply | Threaded
Open this post in threaded view
|

Re: 6.6-current #590 error

rgcinjp
On Thu, Jan 09, 2020 at 07:35:17PM +0900, rgc wrote:

> misc@
>
> just a heads-up #590 has some issues.
>
> $ uname -a
> OpenBSD pcfj10.my.domain 6.6 GENERIC.MP#590 amd64
>
> $ pkg_info -mz
> Cwd.c: loadable library and perl binaries are mismatched (got handshake key 0xb700000, needed 0xb600000)
>
> yorosiku ~
>

misc@

loaded up #594 and had the same issue. but i have another machine that i just
updated to the same snapshot. this other machine is running properly. so it is a
problem on my setup on this particular laptop.


a hint came up after executing LD_DEBUG=1 perl `which pkg_info`

doing dtors obj 0x5cb5a122800 @0x5cb0d78b7c0: [/usr/local/libdata/perl5/site_perl/amd64-openbsd/auto/Cwd/Cwd.so]

after moving the [/usr/local/libdata/perl5] directory, everything went fine.
perl seems to have re-created the files with latest versions.

yorosiku ~