3.9 plone port problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

3.9 plone port problem

Antonios Anastasiadis
I have installed zope and plone and followed the simpled instructions
in the zope README.OpenBSD to create a zope instance.
Zope works ok, but I can there is no "Plone Site" to add in the plone
management ZMI list, and CMFPlone does not appear in the products list
anyway.
Digging through zope events.log file has the following:

2006-10-09T00:41:38 ERROR Zope Couldn't install CMFPlone
Traceback (most recent call last):
  File "/usr/obj/i386/zope-2.8.4/fake-i386/usr/local/lib/zope/lib/python/OFS/Application.py",
line 773, in install_product
  File "/usr/local/lib/zope/lib/python/Products/CMFPlone/__init__.py",
line 101, in initialize
    migrations.executeMigrations()
  File "/usr/local/lib/zope/lib/python/Products/CMFPlone/migrations/__init__.py",
line 4, in executeMigrations
    import v1, v2, v2_1
  File "/usr/local/lib/zope/lib/python/Products/CMFPlone/migrations/v1/__init__.py",
line 11, in ?
    import rc1_rc2, rc2_final
  File "/usr/local/lib/zope/lib/python/Products/CMFPlone/migrations/v1/rc1_rc2.py",
line 2, in ?
    from Products.CMFPlone.Portal import PloneGenerator
  File "/usr/local/lib/zope/lib/python/Products/CMFPlone/Portal.py",
line 30, in ?
    from Products.CMFDynamicViewFTI.browserdefault import BrowserDefaultMixin
ImportError: No module named CMFDynamicViewFTI.browserdefault

There is no CMFDynamicViewFTI product in the
/usr/local/lib/zope/lib/python/Products directory. Shouldn't it be
there?
This is a brand new 3.9 installation with packages directly installed
from an ftp mirror.
Am I the only one having the same problem?

Reply | Threaded
Open this post in threaded view
|

Re: 3.9 plone port problem

Antonios Anastasiadis
searching through the archives more thoroughly I found another one
that has the same problem, so I guess that the 3.9 plone port is
broken.